0

I have a new RPi 4 and I have installed NOOBS from a zip due to the fact that I cannot install software on my computer as it is loaned from my school (i.e. image writing software)

However, once plugged in to a power source, there is just a singular red light and the green light flashes once really quickly.

I read an article online (https://www.makeuseof.com/tag/raspberry-pi-wont-boot-fix/) which said that if the OS was not supported there would only be a red light and no green light, so I wondered if there was any way to install the latest RPi OS version from a zip file rather than an image?

(I tested my download of NOOBS on a RPi Model B [https://socialcompare.com/en/review/raspberry-pi-model-b] and it worked)

1
  • You might download a portable disk imager (Pi foundation refers a.o. to upswift.io/imgflasher) and use that if you're on Win10. No need for a real install and you can remove it after use. Jun 17 at 11:45
0

To answer the actual question - the only ways to install an OS without an installer are NOOBS or PINN, which are OS installer/boot managers. Few (if any) experienced users on this site use NOOBS, and even on the Foundation site it is discouraged.

If you do want to pursue this I believe NOOBS is still available, and should run on Pi4 - obviously I haven't tried this.

Many of the NOOBS disks supplied by vendors are obsolete.

A better (and more capable and flexible) option is PINN

NOTE to use either of these you NEED a screen and keyboard

It is possible to install an (uncompressed) image using dd which is ubiquitous on Linux and Unix based OS (including macOS)

If you have another Pi and a SD adapter you can install Raspberry Pi Imager on the Pi (assuming you have sufficient space for the image).

1
  • Both of NOOBS and PINN worked on the RPi-B but not on the RPi-4. I also tested my micro sd (used for RPI-4) in an SD adapter in the RPi-B and that didn't seem to work either. It may just be an issue with my SD card? Is there any storage size limits that I possibly missed out on? Jun 17 at 11:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.