0

I've installed Raspberry Pi OS Lite on flash drive with Raspberry Pi Imager. After that I've added SSH and wpa_supplicant.conf (I've taken this example to create the config). And after that I've plugged micro-SD card into Raspberry Pi and turn power on. Red (PWR) and Green (ACT) leds light up. As it's stated in numerous manuals I should be able to connect through SSH after that. But when I try to do ssh [email protected] (I'm using Windows 10) I get ssh: Could not resolve hostname raspberrypi.local error, putty gives the same result. I've tried to connect Raspbery PI to router with LAN cable, but the result was the same. Moreover, I do not see Raspberry Pi in Network.

I'm sure I've done some stupid error. How can I troubleshoot the problem?

1
  • 1
    1. Did you make sure you waited a couple of minutes after the first boot before SSHing? 2. Did you input the correct SSID, password, and country-code into wpa_supplicant.conf? 3. Also did you trying using "ssh" instead of "SSH" for the name of the file? 4. Are those files on the "boot" partition? (They will be the only readable drive in Windows) 5. Also I would try recreating the supplicant file using the official foundation guide. Jun 20, 2021 at 13:29

2 Answers 2

1

Assuming you've cleared the suggestions offered in @UnsignedArduino's comment, the error you've reported: ssh: Could not resolve hostname raspberrypi.local suggests a networking issue. Without information on your network configuration, the best we can do is guess. Here's a start:

The raspberrypi.local network name is made possible through zero configuration networking. Does your Windows host support this? If not - you should be able to find a software package that will add that support. Know also that these network names used in zero config networking may take some time to propagate through the network.

Does your network have a DHCP server - a router/modem/firewall that assigns IP addresses to the other machines on your network, and provides DNS on your LAN? If so, it's possible your RPi has gotten an IP address, but your Windows host is not configured properly. Two ideas:

  • look at the DHCP leases in your router/modem/firewall, and find the address assigned to the RPi.

  • If that's not possible, you can try pinging all of the hosts on your network to locate your RPi by its MAC address. If you have a system that has bash installed, the script here may help. If not - or you need to do this from your Windows machine, this Q&A may help.

Hope this helps - feel free to edit your question to add information, or seek more details in the comments.

0

While it is possible to enable headless setup with ssh and wpa_supplicant.conf this assumes the wpa_supplicant.conf is correct and in the correct format (which Windows doesn't use by default).

Also Windows did/does use .local in a non-standard way (although this seems to change with version).

If you really MUST do a headless setup (which is difficult, even for an experienced user) I strongly recommend using the latest Raspberry Pi Imager.
There are advanced options, invoked by the magic key sequence: Ctrl-Shift-X.

These enable you to set many initial options; hostname, password, ssh, WiFi Country Code etc during imaging.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.