1

I installed Raspberry Pi OS on an old microSD card I had, which I put in my new Raspberry Pi 4 (8GB RAM). Today, I tried to (safely) overclock the system. However, when I rebooted the system, I got an error message. Since the Pi started to get hot, I unplugged its power cord. I then tried to reinstall the OS on the SD card, but now Windows won't recognize when I plug the drive in. Is there some way to fix the microSD card, or is it completely broken?

For reference, when I put the SD card in my phone, it recognizes it, just not on the Windows desktop. I've tried to reset the microSD card on my phone then program it on my Windows. At first, this seems to work, but after the Raspberry Pi Imager writes to the drive, the computer stops recognizing the drive, and when I try to install the drive on the Raspberry Pi, it doesn't recognize that a drive has been plugged in.

2
  • not a Raspberry Pi specific question ... try running a linux live distribution such as Mint, on your PC ... it may be able to read the SD card
    – jsotola
    Jun 20 at 20:31
  • You could run fsck on your SD card in an effort to diagnose/fix any corruption. However, you'll need a Linux system to do that.
    – Seamus
    Jun 20 at 21:04
0

As others have suggested, it sounds like an issue with your SD card. Your idea to re-flash the SD card with the Raspian OS sounds like a good idea. But it sounds like it's failing.

Try running DiskPart to fully clean out the card, and the re-flash it (aka run the Raspberry Pi imager). You can see more here.

extras I have to warn you that if you see there's only about 32MB of storage in your SD card, it probably means your SD card is physically broken. This happened to me. I have a 16GB SD card but only 32MB showed up in DiskPart. Upon closer examination, there was a noticeable crack running through the card.

0

If the Raspberry Pi Imager fails the SD Card is almost certainly damaged.

If you run the SD Card Formatter and perform a full format (which takes quite a while - often > 15minutes, depending on size) you MAY then be able to install an image using Raspberry Pi Imager, but the problem may re-occur if the card is worn out.

Formatting using other tools is usually a waste of time as ther don't fully erase the card.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.