0

I can't figure out why I can't connect to my Raspberry Pi using ssh over IPv6.

I've modprobed the ipv6 module and modified /etc/sysctl.cfg to include

net.ipv6.conf.all.disable_ipv6 = 0
net.ipv6.conf.default.disable_ipv6 = 0

I also explicitly added

Listen ::

to my /etc/ssh/sshd_config.

I can ssh out to other machines using ipv6; and I can ssh in using ipv4. But connecting using

ssh ::1

gives me

ssh: connect to host ::1 port 22: Connection refused

(This also happens when I try to connect from an external box, but I figure I have to fix being able to connect to localhost before I try outside addresses.)

It doesn't seem to be a firewall issue. ip6tables tells me

Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

So it doesn't look like there's any there there.

What else could be blocking me from connecting via ipv6?

(And yes, in theory I could just give up and go back to my NATted IPv4 address, except that this is a Kodi machine, and I'm setting up a share over a VPN for my media files, and the VPN is set up for ipv6.)

This is on Xbian 10, which is based on Raspbian via Debian buster.

Thanks.

3
  • So netstat is showing the ssh port open on IPv6? Does the sshd log contains any entries if you try to connect?
    – Robert
    Jun 21, 2021 at 18:47
  • Good questions. netstat doesn't show a listener on port 22 for tcp6, so looks like for some reason the daemon isn't listening for ipv6 connections even though I specified "Listen ::".
    – Creede
    Jun 21, 2021 at 20:03
  • Please Edit your question and add the output of this command to it: ip addr.
    – Ingo
    Jun 21, 2021 at 20:55

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.