0

I got an Raspberry Pi 4 4GB running Ubuntu 21.04 Desktop. I want to connect via ssh to my Raspberry Pi Zero (without Wireless) running Raspbian lite. For the ssh setup i followed the instructions stated here: Headless Pi Zero SSH access over USB I have done the configuration on the Zero and added a usb0 file to ^path_to_mounted_sd^/rootfs/etc/network/interfaces.d/ containing following lines:

allow-hotplug usb0
iface usb0 inet static
address 192.168.137.2
netmask 255.255.255.0
network 192.168.137.0
broadcast 192.168.137.255
gateway 192.168.137.1

Afterwards i plugged the Zero in the usb port at my Pi 4 and waited until the boot process finished. I set a static ip to the interface of the Pi4 as well. Also i set the Network IPv4 Settings to "link local only". Tried to ssh into the zero and it worked. I scp'ed a python script to the zero. This worked as well. To run the skript i need to install the picamera module to the zero. I tried this but it didn't work (could not connect to the servers). I unplugged the Zero and rebooted it. Now the problem: after unplugging and rebooting i couldn't connect to the Zero via ssh. Error: Connection timed out.

Has anyone an idea how this problem can occur? Is it because of unplugging the zero? Does anyone know a solution for this? Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.