0

I set up a cam server on my LAN. Works perfectly. The server runs on port 8090. I accessed the firewall page of my router (2wire 3800) and forwarded ports 8090 to 8090.

Here is where things get strange.

When I check for open ports by using canyouseeme.org It shows no open ports. I tried opening several different ports out of curiousity and nothing. Then there is an option to allow ALL inbound traffic to my specific device (raspberrypi) so I tried it. When I did this canyouseeme.org could now see open ports but only the ones I allowed through the firewall previously. My raspi now has taken the ip of my external (outward facing) ip address. At this point I decided to see if I could at least see my cam server by having my sister access the page. I directed her (she was on her own network) to access my external ip, lets say 123.123.123.123, by going to h ttp://123.123.123.123:8090/?action=stream .Nothing. I have her ping my outward facing ip and nothing. Im new at this, could someone please help me with what I am missing? Thanks so much!

1

This isn't a full answer but doesn't format well in the comments....

  1. Ping is unlikely to work on a internet address - most routers have 'respond to ping' turned off to foil hackers.

  2. The canyouseeme thing is probably a red herring - if there is nothing to respond to the port scan, it probably won't tell you it's open, so don't be concerned that it's only showing your active ports.

  3. What do you get if you go to a command prompt on your computer (inside the LAN) and type TELNET <your raspberry pi IP> 8090

  4. What do you get if you go to a command prompt on an external computer (not on your LAN) and type TELNET <your router external internet IP address> 8090

Regardless you need to first follow Chewie's advice and get your internal IP address and port forwarding sorted properly.

0

If your RPI has the external IP address, you might try to disable the port forwarding. But that's not a great solution.

You should give a static internal IP to the RPI and then on your router make the por t forwarding to that IP on the 8090 port. Can you give all the port forwarding setup config ?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.