1

I am trying to run my Raspberry Pi as a kiosk and users keep hitting F1 which opens Google Help. How do I disable this?

For reference I am running the following on boot

chromium-browser --kiosk --app=http://localhost:1880/ --noerrdialogs --disable-sesion-crashed-bubble --disable-infobars --check-for-update-interval=604800 --disable-pinch

I tried to disable the key by adding xmodmap -e 'keycode 67=' to the /etc/xdg/openbox/autostart

EDIT: When I run xmodmap -e 'keycode 67= it disables the key which is great but I can't seem to get it to work on boot

2 Answers 2

1

It could be that your troubles are related to the desktop environment you are using. Many of DEs handle some keys for their own use before they are forwarded to the applications, and this is often the case for Fx keys. It's likely that you disable F1 from the autostart script, and then the DE re-enables it.

Look into the man pages for your DE to see what options you have regarding Fx keys.

Alternatively, try writing a script which waits for some time (e.g. sleep 10) and then disables F1.

1

I had to remap it to an existing key (remapped to Escape) to make it work.

xmodmap -e "keycode $F1_key_code=Escape"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.