I have a Raspberry Pi 4 8GB that I'm looking to use for ham radio applications. In particular, I'm currently working with an rtl-sdr dongle for software-defined radio. Right now I'm just working with Raspberry Pi reference 2021-05-07.

I don't have space for a monitor on my shelf, so I'm running this machine headless and connecting via VNC Viewer and standard ssh.


has been added to /boot/config.txt.

When I run the following command through the ssh session, I hear audio from a speaker I've plugged into the 3.5 mm jack:

speaker-test -c2 -twav -l7

However, when I run the exact same command through a terminal session in the VNC Viewer session, there's no sound. Furthermore, if I right-click the volume control on the desktop, I get "no audio devices found", despite a slider presenting when I left click on that same icon.

Alsamixer seems to see a headphone jack when adjusted through the terminal in a VNC session:

enter image description here

I'm guessing that VNC is not allowing any audio output. Is there any way to make it play out of the 3.5mm jack while connected to VNC? Not much point to a ham radio application box that doesn't have audio :P

  • don't forget that you are executing the program on a remote machine ... the server that you are connecting to probably plays the sound
    – jsotola
    Jun 26, 2021 at 3:54

2 Answers 2


If you using VNC that comes with the OS, that would be the RealVNC Home Edition, a proprietary software. In order to use audio you need to get Professional or Enterprise version of it, or other software that supports it. None of the TigerVNC, TightVNC, UltraVNC supports audio.


The new realVNC creates a pulseaudio server instance and populates it with a virtual sink (for its remote audio that only works on the paid versions of VNC) and hides the actual 3.5mm jack.

The solution changing the startup files such that it doesn't do that. What worked from me was to copy /etc/vnc/pulse/daemon.conf to ~/.vnc/pulse/daemon.conf and then in the new file commenting out these two lines:

load-default-script-file = yes

default-script-file = /etc/vnc/pulse/default.pa

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.