0

I have a problem with my network interface. My ISP provides a 1000Mbps download connection, but doing a speedtest from my raspberry pi 3b + it stays below 10Mbps so I ran ethtool eth0 and I find that the speed is set to a maximum of 10Mbps how can I increase this speed to enable gigabit?

Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: Symmetric
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Link partner advertised link modes:  10baseT/Half
        Link partner advertised pause frame use: No
        Link partner advertised auto-negotiation: No
        Link partner advertised FEC modes: Not reported
        Speed: 10Mb/s
        Duplex: Half
        Port: MII
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
Cannot get wake-on-lan settings: Operation not permitted
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: yes

2 Answers 2

1

The reason it uses 10Mbps is because whatever it is connected to only supports 10Mbps.

Link partner advertised link modes:  10baseT/Half

A Gigabit router would say something like:-

Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                     100baseT/Half 100baseT/Full 
                                     1000baseT/Full 
Link partner advertised pause frame use: Symmetric
Link partner advertised auto-negotiation: Yes
Link partner advertised FEC modes: Not reported
3
  • thanks, but it's strange because all my router ports provide gigabit and I did the test by connecting with the same cable (Cat.5E) to the same LAN port from a laptop doing a speedtest I arrive safely at 800Mbps so how can it be the cable or the router if everything works with another device?
    – Bolzo13
    Jul 2, 2021 at 7:09
  • @Bolzo13 whatever the cause of your problem it won't be the Pi, because it its doing what it was told.
    – Milliways
    Jul 2, 2021 at 7:59
  • This morning a friend lent me his PI4 to do a test, connected to the same port on my router and with the same cable the result is clear 800Mbps in download. I deduce that the problem whatever it is lies in my PI3B + and at this point I will opt to upgrade to PI4 too Settings for eth0: Supported link modes: 10baseT/Half 10baseT/Full 100baseT/Half 100baseT/Full 1000baseT/Half 1000baseT/Full Link partner advertised link modes: 10baseT/Half 10baseT/Full 100baseT/Half 100baseT/Full 1000baseT/Full Speed: 1000Mb/s Duplex: Full Auto-negotiation: on
    – Bolzo13
    Jul 2, 2021 at 9:56
0

According to the specs your model (3B+) will not run at full gigabit ethernet speed due to the limitations of the USB bus:

Gigabit Ethernet over USB 2.0 (maximum throughput 300 Mbps)

Consider upgrading to a RPI 4 if speed is important to you.

But what about your router and switch ? Any device standing between your ISP modem and your Rpi can potentially be slowing you down. 100 Mb ethernet interfaces are still common on domestic network appliances.

Ethernet cables ? You should have at least CAT5e/CAT6 cables to take advantage of that speed.

Try to make a direct connection from the Rpi to your Internet modem (or FTTH or whatever) with a quality ethernet cable, and measure performance again.

5
  • In addition to the above: Link partner advertised link modes: 10baseT/Half and Link partner advertised auto-negotiation: No seem to be confirming the point made about 'the weakest link'
    – Dirk
    Jun 30, 2021 at 19:10
  • What is a RPi 4+? I only know a RPi 4B.
    – Ingo
    Jun 30, 2021 at 20:11
  • Hi, my RPI is directly connected to the FTTH modem via a 0.5m long UTP Cat5E cable from any other cable connected device the download speed approaches 850Mbps while the speedtests from the RPI go up to 9Mbps maximum in eth0 and maximum 90Mbps in wlan0 . I also tried to run ethtool eth0 speed 1000 duplex full autoneg on but doing so the interface goes as down. I was just looking for the latest tips before updating to an RPI4
    – Bolzo13
    Jun 30, 2021 at 21:26
  • @Bolzo13 - changing the device that is working won't fix a device (or cable) that isn't - i.e. the 3B+ is not the issue, it's either the cable or the device directly at the other end of the cable Jun 30, 2021 at 23:33
  • Long discussion on Rpi forums that touches on the issue and mention possible issues with kernel.
    – Kate
    Jul 1, 2021 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.