0

I used the included SD card to install my raspbian (Buster, I think) on a 32GB card. For some reason the card filled up (that will be a question for another day), so I copied an image of the card to a 256GB card (using dd on a Mac). But the filesystem still reports the card is almost full. Here's the df -h:

Filesystem      Size  Used Avail Use% Mounted on
/dev/root        27G   25G  896M  97% /
devtmpfs        3.8G     0  3.8G   0% /dev
tmpfs           3.9G  377M  3.5G  10% /dev/shm
tmpfs           3.9G  8.7M  3.9G   1% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           3.9G     0  3.9G   0% /sys/fs/cgroup
/dev/loop0       92M   92M     0 100% /snap/qbittorrent-arnatious/43
/dev/loop1       46M   46M     0 100% /snap/core18/2067
/dev/loop2       92M   92M     0 100% /snap/qbittorrent-arnatious/73
/dev/loop3       46M   46M     0 100% /snap/core18/2072
/dev/loop5       66M   66M     0 100% /snap/gtk-common-themes/1515
/dev/loop4       65M   65M     0 100% /snap/gtk-common-themes/1514
/dev/loop6       46M   46M     0 100% /snap/core18/2001
/dev/mmcblk0p6  253M   49M  204M  20% /boot
tmpfs           788M  8.0K  788M   1% /run/user/1000
/dev/sda2       1.9T  1.1T  792G  58% /media/pi/SYD_STUFF

So I ran sudo raspi-config and tried expanding the usable space, but it said it couldn't help me because it looked like I had used NOOBS.

Your partition layout is not currently supported by this tool. You are probably using NOOBS, in which case your root filesystem is already expanded anyway.

And yet, the rPi sees the 256G. Here's the sudo fdisk -l:

Disk /dev/mmcblk0: 238.3 GiB, 255869321216 bytes, 499744768 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xd5282710

Device         Boot   Start      End  Sectors  Size Id Type
/dev/mmcblk0p1         2048  4978515  4976468  2.4G  e W95 FAT16 (LBA)
/dev/mmcblk0p2      4978516 62333951 57355436 27.4G  5 Extended
/dev/mmcblk0p5      4980736  5046269    65534   32M 83 Linux
/dev/mmcblk0p6      5046272  5570557   524286  256M  c W95 FAT32 (LBA)
/dev/mmcblk0p7      5570560 62333951 56763392 27.1G 83 Linux

So, how do I get the rPi to recognize and use the entire 256G card?

Thanks for your help.

7
  • 2
    Don't use NOOBS - too late now, start again without NOOBS Jul 3 at 17:00
  • 1
    or, you may be able to use the SD CARD Copier - you do that in a running system, so you'd need a USB->SD card adapter Jul 3 at 17:03
  • Perhaps this will help Jul 3 at 17:14
  • I can probably start over without NOOBS. Jul 3 at 17:29
  • then do that :p by far the safest option Jul 3 at 17:30
0

You are using NOOBS (which the Foundation now hides from unsuspecting novices).

If you want multi OS support try PINN

The reason you can't expand the filesystem is because dd copies the device as it is, including the partition table, which continues to think it is 32GB.

If you used SD CARD Copier it would expand/contract to the actual size of the target device and automatically adjust the size of the last partition, so you COULD use this to expand.

I do not recommend this; the space wasted on such a large device is not significant, but NOOBS just makes everything more difficult, so your best option is to perform a fresh installation of Raspberry Pi OS.

You could copy the contents of your home directory (from the 32GB original) if you have anything worth keeping.

1
  • As both @Milliways and @Jaromanda X suggested, easiest to simply start over. As it turns out, I came across the process of identifying what exactly is taking up so much damn space. du -sh * shows you the size of all the directories in your current working directory. So I was able to find the problem dir, investigate the issue, and remediate it. So, even with my 32GB-sized partition, I'm down to using only 20% of it. Yay! Jul 5 at 4:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.