RasPi 4B

When I edit config.txt, trying to force a certain resolution, RasPi always comes up with the monitors preferred resolution. After a lot of trying, including a completely new fresh OS install, I have come to the suspicion that when the desktop initialises, it also re-re-initializes HDMI So the read of config.txt done by the GPU at boot is undone.

However, when I edit the resolution with the Preferences->ScreenConfiguration, that one holds, but it does not modify the /boot/config.txt. So that utility is someone called during desktop start and is my undoing.

I am pretty sure about this: When I manually edit config.txt, depending on the modes that I select, I quickly see the boot logo pass at various sizes, depending on the mode I did set. But it always flashes again when the final desktop loads and jumps to the resolution set with the utility.

Can anyone confirm? How to disable the utility? From SSH preferably. Or better yet, how to also add custom resolutons into that?

BTW: the mode I am trying to set is a DMT mode. (I tried with and without the :0 of course)


1 Answer 1


For most Pi the resolution can only be set at boot. This is used in console mode and in GUI.

The Pi4 can do also this, but the resolution can be changed in in real time in the GUI, and set independently for each HDMI port.

If the "Pi always comes up with the monitors preferred resolution" you are doing something wrong. Indeed the Pi4 will not enable any resolution unless it detects a monitor, but you can set a default (which applies even with no monitor), although it your monitor does not support this I am unsure what happens.

Any change to the resolution in the GUI does not affect the default set for boot in console mode. However if you explicitly set resolution in ScreenConfiguration it should be applied on entering GUI. (It is possible to restore to default, but I don't remember how or where this is stored.)

See https://www.raspberrypi.org/documentation/configuration/config-txt/video.md

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.