I'm trying to pair an Xbox Series X controller to my Raspberry Pi 4B, but I've had no luck despite following all online instructions. I've disabled ERTM by running echo 'options bluetooth disable_ertm=Y' | sudo tee -a /etc/modprobe.d/bluetooth.conf and rebooting. At the terminal, bluetoothctl reports that the pairing for was successful, but the Xbox logo doesn't stop flashing and the controller seems to get stuck in a connection/disconnection loop if I switch it off and attempt to connect it again.

I've also tried installing the xpadneo driver which should disable ERTM automatically, but that didn't work either. The controller is running the latest firmware.

I'm currently on the latest version of Raspbian (Buster) and Linux kernel 5.10.17. Is there a new way to disable ERTM, or could it be something else?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.