3

I'm running Raspbian and everything seems to be running smoothly. When I run a man page, I can scroll up and down to read it. When I run a command, such as 'command --help | less' or 'command -h | less', it prints everything and then reaches the end. If I hit 'q', I can quit, but otherwise, I can't scroll back up to see what I missed. Page Up/Down don't work, nothing, I've never had this kind of problem with more/less before. When I try to hit another key, it just prints out a single column of tildes on the left side, kind of like I'm in vim suddenly. Maybe that'll help?

Any ideas? It's just an annoyance, and I know I can look these things up on the internet, but if I take my Pi out into the field and don't have that luxury then I'm stuck. Sorry if this is the wrong place to post this; I didn't think that a linux place was correct since I've never had this happen before on any other version of linux. A google search on this is impossible given the words "less" and "more"...

3
  • Can you scroll using vi-keys (j/k for up and down)? If so, I guess you have a problem with your terminal settings. Which terminal emulator are you using, what content does the TERM variable on the Pi have?
    – Arne
    Jan 7, 2014 at 15:16
  • PgUp/PgDown work for me. Are you accessing the pi remotely, and if so, what are you using?
    – goldilocks
    Jan 7, 2014 at 16:02
  • I have the Pi hooked up directly to everything. Page Up/Down produce the same thing as Up/Down. Most key strokes reproduce this problem but some do nothing (g,k will reproduce this, but j will do nothing). Trying now, if I press 'h', it brings me to the "summary of less commands" page... from command --help | less. TERM is set to 'linux'. I'm running bash.
    – Michael
    Jan 7, 2014 at 16:30

1 Answer 1

1

The only less commands I really use are:

  • g — go to top of file
  • G — go to bottom of file
  • b — page up
  • Space — page down
  • / — find (regex)
  • . — find next

Some Linux installations have PgUp and PgDn defined, but these always work. I have never learnt vi keys, despite using Unix since the late 1980s.

2
  • 1
    ? - searches backwards and F - scroll forward and try to read more when at end of file (behaves like 'tail -f') Apr 7, 2014 at 17:34
  • All of these commands produce a column of ~ as the OP experienced. May 4, 2014 at 22:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.