0

I have Razberry PI Zero W and I am trying to setup wifi connection. Our apartment has multiple APs with the same name. Routers work on the 2.4 and 5 GHZ frequency. I cannot access those routers.

I tried connecting to phone AP and it works, however I cannot connect to other APs.

country=SI
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="name"
    scan_ssid=1
    psk="pass"
    key_mgmt=WPA-PSK
}

Am I doing something wrong?

Edit: I am editing a file /Volumes/boot/wpa_supplicant.conf

9
  • I'd also suggest checking that the AP your connecting to isn't set to auto 5ghz/2.4ghz and that the bands have been separated I.e. a specific AP for each band. I've had issues in the past where a pi0 wouldn't connect to a network because the bands weren't separated and the pi basically got confused. That it works with the phone would suggest the phone is broadcasting on the 2.4ghz which is usually the default. You have to explicitly set it to 5ghz if you want it.
    – rohtua
    Jul 19 '21 at 9:57
  • I take it you can connect your phone the AP without issue? Did you ask this yesterday?
    – Bravo
    Jul 19 '21 at 10:55
  • @rohtua - how can a pi zero be confused by a 5Ghz signal it can't even see!!!???
    – Bravo
    Jul 19 '21 at 10:58
  • @Bravo no it can't see 5ghz networks but if you've got one AP that handles both 5ghz and 2.4ghz on a single SSID (as most routers do by default) it can see the AP but from my own experience it doesn't connect because the router tries to put it onto the 5ghz by default which the pi can't connect to so it just drops the connection. I've found that for best compatibility for Pi's and other 2.4ghz devices you should split the bands so they are broadcast on unique SSID's which tends to improve things anyway.
    – rohtua
    Jul 19 '21 at 11:18
  • 1
    As in your earlier deleted question you have provided no details, no diagnostics. Look at dmesg and systemctl status dhcpcd. Don't use scan_ssid=1 unless the network is hidden. Did you try connecting in the GUI?
    – Milliways
    Jul 19 '21 at 12:03
1

The Pi zero doesn't support 5GHz WiFi, so it simply doesn't see the 5GHz networks and doesn't care about their names. The reason your Pi doesn't connect is likely elsewhere.

I would start by setting the country code via Localisation Options item from the menu, and configure the connection using raspi-config.

Also try connecting your phone to the router, and make sure your phone is using 2.4GHz WiFi, otherwise the fact that it connects to a 5GHz AP doesn't mean the Pi would be able to connect to 2.4GHz with the same password.

4
  • 1
    I think the OP was saying he can connect the pi to a phone AP - also looks like OP has set the country code to SI
    – Bravo
    Jul 19 '21 at 10:56
  • @Bravo You are right, and connecting the phone to the router is something he should nevertheless try. I've seen the country code line, though it's not clear whether it's a command or part of a file, and, assuming it's part of a file I don't know if changing the locale via the menu has other effects. Jul 19 '21 at 12:20
  • Yes, I did successfully connect to phone AP, and I am using 2.4ghz band.
    – Matej J
    Jul 19 '21 at 12:28
  • Nevermind, solved it
    – Matej J
    Jul 29 '21 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.