So as the title says, I've been trying to share the internet from my pc to my pi, running the pi headless and remotely connecting to it and whatsoever. However, whilst I can just do a remote connection to it just by using its hostname, it refuses to connect to the internet, always giving out the address 169.254.x.y meaning that it could not find a DHCP server.

My current config The PC has network sharing enabled, sharing to the ethernet port. The ethernet was given the static address of, with its subnet mask being the usual It worked when I did it like 3 days ago, but it does not want to work now. Checked the cables for damage, switched them even but still no success. Restarted my pc to see if there'd be any change, but nothing happened.

Is there anything that can be done about this? I have tried to find a solution to this problem all over the web but it seems I'm only experiencing this specific issue.

  • This appears to be a variation on your previous questions. You don't provide any details so no one can help.
    – Milliways
    Jul 27, 2021 at 22:40

1 Answer 1


Try connecting the pi to your router without the pc in the way and see if it gets an IP address. If it does then the problem is with your pc not responding to DHCP requests.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.