3

I am running a bunch of class Raspberry Pi computers behind a school proxy. I'm using Raspbian off a very recent NOOBS image. The internet connection is supplied through the school WiFi and after logging into LXDE I login to the proxy server through a web interface and test that I can access pages.

Running:

sudo apt-get update

I get the following

Hit http://raspberrypi.collabora.com wheezy Release.gpg
Hit http://archive.raspberrypi.org wheezy Release.gpg 
Hit http://raspberrypi.collabora.com wheezy Release 
Hit http://archive.raspberrypi.org wheezy Release 
Hit http://raspberrypi.collabora.com wheezy/rpi armhf Packages 
Get:1 http://raspberrypi.collabora.com wheezy/rpi Translation-en_GB 
Get:2 http://raspberrypi.collabora.com wheezy/rpi Translation-en 
Hit http://archive.raspberrypi.org wheezy/main armhf Packages 
Get:3 http://archive.raspberrypi.org wheezy/main Translation-en_GB 
Get:4 http://archive.raspberrypi.org wheezy/main Translation-en 
Hit http://mirrordirector.raspbian.org wheezy Release.gpg 
Hit http://mirrordirector.raspbian.org wheezy Release
Hit http://mirrordirector.raspbian.org wheezy/main armhf Packages
Hit http://mirrordirector.raspbian.org wheezy/contrib armhf Packages
Hit http://mirrordirector.raspbian.org wheezy/non-free armhf Packages
Hit http://mirrordirector.raspbian.org wheezy/rpi armhf Packages
Get:5 http://mirrordirector.raspbian.org wheezy/contrib Translation-en_GB
Get:6 http://mirrordirector.raspbian.org wheezy/contrib Translation-en
Get:7 http://mirrordirector.raspbian.org wheezy/main Translation-en_GB
Get:8 http://mirrordirector.raspbian.org wheezy/main Translation-en
Get:9 http://mirrordirector.raspbian.org wheezy/non-free Translation-en_GB
Get:10 http://mirrordirector.raspbian.org wheezy/non-free Translation-en
Get:11 http://mirrordirector.raspbian.org wheezy/rpi Translation-en_GB
Get:12 http://mirrordirector.raspbian.org wheezy/rpi Translation-en
Fetched 46.1 kB in 7s (6,587 B/s) 
Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/mirrordirector.raspbian.org_raspbian_dists_wheezy_contrib_i18n_Translation-en
E: The package lists or status file could not be parsed or opened.

Now I've spent about a day researching this error and the solution which is offered most of the time is:

sudo rm /var/lib/apt/lists/* -vf 
sudo apt-get update 

Which I've tried but doesn't work at all as when I run update again I get the same problem.

  • Have you checked such obvious things, e.g. like enough free disk space? – Arne Jan 10 '14 at 15:09
  • Also, have you tried running sudo apt-get -f update? It tries to fix issues like this. – RPiAwesomeness Jan 10 '14 at 15:11
  • 1
    @Arne - fresh install on an 8GB sd card - should be ample space – sharland Jan 10 '14 at 15:32
  • @RPiAwesomeness - just tried that and I continue to get the exact same error – sharland Jan 10 '14 at 15:39
  • Try these: sudo dpkg --configure -a & sudo aptitude update& sudo aptitude upgrade. aptitude can be swapped out for apt-get if aptitude isn't installed. – RPiAwesomeness Jan 10 '14 at 15:44
3
  1. Try these: sudo dpkg --configure -a & sudo aptitude update & sudo aptitude upgrade. aptitude can be swapped out for apt-get if aptitude isn't installed.

If the dpkg command fails, try running sudo rm /var/lock/dpkg/status and then touch a new one via sudo touch/var/lock/dpkg/status. Fixed another user's problem here: raspberrypi.org/phpBB3/viewtopic.php?t=11824.

  • I tried the following sudo dpkg --configure -a which returned me straight to the prompt. I then ran sudo aptitude update which produced similar errors to my original post. I then tried sudo rm /var/lock/dpkg/status which resulted in 'no such file or directory' and then tried sudo touch /var/lock/dpkg/status which also resulted in 'no such file or directory'. Unfortunately this means I am still unable to solve my original problem. – sharland Jan 15 '14 at 13:25
  • Well, that may be what is causing the problem. If files for dpkg are missing, then that means apt-get is going to fail, as it is just a pretty front-end to dpkg. All package control going on in a raspbian (debian) system is done through dpkg (.debs, apt-get, aptitude, etc.) My guess is that something was messed up during installation or something happened since then that has messed up dpkg...beyond that it's hard to diagnose... – RPiAwesomeness Jan 15 '14 at 13:28
  • 1
    Your link posted above also suggested sudo rm /var/lib/dpkg/status and sudo touch /var/lib/dpkg/status which both worked or didn't return error messages. However sudo apt-get update still fails after that. I'm going to try a new NOOBS img, install Raspbian from that and try again. – sharland Jan 15 '14 at 13:34
  • @sharland You can create a self-answer and then mark it... – RPiAwesomeness Jan 15 '14 at 16:05
3

The error saying "Problem with MergeList /var/lib/..." indicates that the status file got corrupted for some reason, and so cannot be parsed. This status file contains information about installed deb packages, and thus needs to be carefully backed up.

In this case, since this is freshly installed Raspbian, you can safely remove the status file, and re-generate it as follows.

$ sudo rm /var/lib/dpkg/status

$ sudo touch /var/lib/dpkg/status

$ sudo apt-get update

  • This one worked for me... – PGallagher Nov 28 at 22:23
1

I had the same problem, didn't managed to resolve with solution proposed by @RpiAwesomeness, but I managed to resolve with the following commands:

sudo rm /var/lib/apt/lists/* -vf
sudo apt-get update
0

Further testing has been done using a number of different SD cards and this issue appears 'solved'. I have not been able to diagnose why sudo apt-get update fails as in original question. However after writing the most recent Raspbian img to a formatted SD card I was able to run sudo apt-get update with no issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.