4

I am trying to make a Raspbian kernel to support real time.

To do that I cloned the latest kernel from raspbian github repository and applied the Real Time patch for 3.10.25-rt23 (https://www.kernel.org/pub/linux/kernel/projects/rt/3.10/).

I followed this link for compilation: http://elinux.org/RPi_Kernel_Compilation

When I compiled it with Desktop Latency config, it is OK, however with CONFIG_PREEMPT_RT_FULL option, it reboots but stops after some seconds.

It finally prints the below lines and then stops there and does not go any step further. Do you have any idea to solve this, or any recommendation for me ?

My opinion is that the problem is with SDCard. SD card can not be mounted because I see the log of sdcard mounting after this lines when I reboot it with running non-rt kernels.

... ... [ 3.523322] usb 1-1.2: Manufacturer: Logitech [ 3.551044] input: Logitech USB Receiver as /devices/platform/bcm2708_usb/usb1/1-1/1-1.2/1-1.2:1.0/input/input0 [ 3.583661] hid-generic 0003:046D:C52B.0001: input,hidraw0: USB HID v1.11 Keyboard [Logitech USB Receiver] on usb-bcm2708_usb-1.2/input0

3

I found the solution to my problem. Maybe it helps for others.

If you are running RT Kernel on Raspberry pi and having a problem to mount root file system, then add the following option to BOOT/cmdline.txt file.

sdhci_bcm2708.enable_llm=0

It has already mentioned and solved in the following post

http://www.raspberrypi.org/phpBB3/viewtopic.php?t=39951

  • Great! Glad you solved it yourself! Once you can, could mark this answer as answer? You can do that on your own answers, Thanks! – RPiAwesomeness Jan 11 '14 at 13:01
0

There is a new branch in the raspbian git that has the rt patches applied. Here is the announcement: https://www.raspberrypi.org/forums/viewtopic.php?f=117&t=206747

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.