1

My Raspberry Pi Model B Board works with RCA output, but do not work with HDMI, after it shows the splash screen. (curiously enough, it shows the splash screen, then a white screen with an option to press SHIFT - after that the TV shows "NO SIGNAL").

It is strange because the HDMI output worked before with another LCD TV which I don't have anymore. Now, with an LG TV the HDMI is not working, even when I change the config.txt, as suggested by other peopl people.

I tried uncommenting:

hdmi_force_hotplug=1
hdmi_drive=2
config_hdmi_boost=4

But it didn't work! It worked when I uncommented:

hdmi_safe=1

However the resolution looked awful. I changed the HDMI cable, I inverted the cables, I switch on the Raspberry after the TV was on and the right input (HDMI) was selected.

Could this be a resolution problem?

1

In your terminal type sudo nano /boot/config.txt

Edit your config.txt by inserting the parameters below. The last two parameters will set your TV resolution & refresh rates, get your TV specs from the manufacturer.

Open another terminal and run the command tvservice -m CED for hdmi_group=1 or tvservice -m DMT for hdmi_group=2 to determine if your TV mode is in the CED or DMT group.

Then set the hdmi_group=1 if CED and do vice versa. Note the mode number and set the hdmi_mode=*.

disable_overscan=0
config_hdmi_boost=4
hdmi_ignore_cec_init=1
hdmi_ignore_cec=1
hdmi_force_hotplug=1
hdmi_ignore_edid=0xa5000080
hdmi_group=2
hdmi_mode=81

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.