6

I have an Edimax EW-7811UN WiFi dongle and I want to use it to connect to my WiFi on Arch Linux 3.10.18-1-ARCH+ (taken from the login prompt, not sure if that's correct. I'm new to Arch). I went with Arch because it is supposed to be lighter. If Raspbian would be a better choice for running a very small Bukkit server, please let me know, as that's my current project that I'm doing for the kicks.

I would like to do most of my work on the Pi over SSH , as the screen I have really sucks and everything is really tiny and I have to sit way hunched over to use the Pi.

However, I can't download updates or the stuff needed to run the server. I have been googling around and everything I see says I have to use pacman, but that is out of the question, as I have no access short of the WiFi adapter (I can't get the Pi close enough for ethernet to the router.)

I have looked at this question and this thread, which tells me to run dmesg -v | grep usbcore which returns a bunch of stuff, and the response closest to the one the thread says to look for, is rt18192cm. However, searching that in Arch AUR doesn't return anything.

This thread looked like it would work, but the top link is dead!

What should I be looking for? I am comfortable with compiling software, if need be, and I have a USB hub, so I can transfer files to the Pi that way. Where can I find the driver necessary to run this dongle and how should I install it?

  • You have an up-to-date version of Arch Linux, right? – syb0rg Jan 14 '14 at 0:32
  • @syb0rg I believe so. Downloaded it from the RPi site less than 2 weeks ago. – RPiAwesomeness Jan 14 '14 at 0:34
  • 1
    Can you get access to internet temporarily? Even if you have to run commands blindly? It would make all of this a lot easier. – syb0rg Jan 14 '14 at 0:36
  • I could try... what commands? – RPiAwesomeness Jan 14 '14 at 0:36
8

The driver you need is in the repositories.

pacman -Sy dkms-8192cu

If you could get internet access temporarily, you could simply download and install it.

  • What keypresses will I have to do after running this command? Eg. y or enter – RPiAwesomeness Jan 14 '14 at 0:41
  • You might have to confirm the download if the files are large enough. Press enter a few times after you enter the command, with some delay in between each key press. – syb0rg Jan 14 '14 at 0:44
  • Ok! Will go and try this! – RPiAwesomeness Jan 14 '14 at 0:44
  • Any easy way to do this offline? In Debian I could probably download a .deb file to USB and install it with dpkg. Is it that easy in Arch? – Victor Van Hee Jun 9 '15 at 12:32
  • 1
    error: target not found: dkms-8192cu. The package you want is called 8192cu-dkms and is in the AUR (i.e., it must be install using an AUR helper, such as packer). – Sean the Bean Oct 14 '15 at 19:43
1

As the commented on @syB0rg's answer by Sean the Bean, you need packer to install the 8192cu-dkms package. To do so:

First install packer

pacman -Sy packer

Than install 8192cu-dkms

packer 8192cu-dkms
1

I was not able to get this wifi dongle working with the dkms-8192cu package, as suggested in other answers. It simply wouldn't recognize the device. Note that dkms-8192cu is currently in the alarm repository, so it can be installed directly with pacman, not from AUR. But since it doesn't work any more, that's not very helpful.

What did work for me was the following:

  1. Installing the rtl8812au-rpi-dkms-git package from AUR using the following commands:

    wget https://aur.archlinux.org/cgit/aur.git/snapshot/rtl8812au-rpi-dkms-git.tar.gz
    bsdtar xzf rtl8812au-rpi-dkms-git.tar.gz
    cd rtl8812au-rpi-dkms-git
    makepkg -si
    
  2. Enabling the use of the wext driver instead of nl80211, which basically means you need to run wpa_supplicant with the argument -Dwext or -Dnl80211,wext. To do that, I followed the suggestion in the arch WPA supplicant page (as root):

    wpa_supplicant my_ssid my_passphrase > /etc/wpa_supplicant/wpa_supplicant-wlan0.conf
    mkdir -p /etc/systemd/system/wpa_supplicant@.service.d
    cat >/etc/systemd/system/wpa_supplicant@.service.d/wext.conf <<EOF
    [Service]
    ExecStart=
    ExecStart=/usr/bin/wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant-%I.conf -i%I -Dnl80211,wext
    EOF
    systemctl daemon-reload
    systemctl enable --now wpa_supplicant@wlan0
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.