I've used my Raspberry Pi before mainly for XBMC (so I know it works and my power supply is okay, etc.), but I want to learn to program a little better, so I've started trying to install Raspbian.

After failing to get it to start using the Raspbian image I've also tried the NOOBS way, but to no avail. The NOOBS bit opens, lets me choose what I want to install, I wait a while for it to finish (which it does), and then it goes off.

No amount of unplugging/replugging things seems to make a difference. The power light comes on and the OK light seems to flash for a while (I assume until I'm supposed to be putting a password in), my screen even comes off standby like it thinks it's doing something, but I get no output.

I've run Raspbian before from a different SD card, though I was hoping to start using my larger one.

What are some things to check or to try?

I've checked the list Working / Non-working SD cards and none of my cards are even on the list, so I'm not sure if it's that.

up vote 2 down vote accepted

The problem was that my SD cards weren't compatible, for a start.

After finding a compatible SD card I had to set up the config.txt file to force output through the HDMI connector: the screen doesn't come on unless there's a signal, and the HDMI doesn't send out a signal until it detects a screen.

Anyway, a simple setup procedure is in RPiconfig.

This happened to me once too. I figured out that I could not see the text asking for my password because the resolution settings were way off. I solved by unplugging and plugging back in. It then waited for it to completely boot and typed my Password in hit enter. Typed my password in hit enter. I was booting to CLI not GUI so I just typed

sudo raspi-config

I went to the advanced options panel to change the resolution. Before leaving raspi-config I went to the Boot Options panel and set it to open to the desktop or (GUI) with no password. Finally I clicked Finish. Remeber the system needs to reboot for the new settings. If you did not get a command prompt to reboot after clicking finish just type

sudo reboot

Problem solved at least for me it was.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.