0

I am stuck on Samba and Mapping a Network Drive from Windows to a Raspberry Pi. Windows Map Network Drive

I have successfully done it on the / directory... But can't seem to do it on the root directory.

Directory has been shared with a chmod -R 777 on the directory. But I can't hit it in Windows with a Map Network Drive. I can if the directory is not right off root.

On Windows 10 - map network drive I am trying: \192.168.1.xxx\ plus tried \192.168.1.xxx\DirectoryName Passwords are correct.

Using on Map Network Drive:

      \\192.168.1.xxx\
      \\192.168.1.xxx\DirectoryName
      \\192.168.1.xxx\root\DirectoryName
      \\192.168.1.xxx\~\DirectoryName

I have tried in Samba Config

      path = DirectoryName 
      path = ~/DirectoryName
      path = /DirectoryName

No luck. Any Linux/Samba/Pi Experts out there? Not a hardware issue.

    [DirectoryName]
       comment = shared without password
       path = /DirectoryName 
       browseable = yes
       writeable = yes
       guest ok = yes
       create mask = 0777
       directory mask = 0777
1
  • Your question is unclear to me. You may wish to make some edits. In particular: I can't hit it : what does that mean? ... successfully done it on the / directory... But can't seem to do it on the root directory?? / is the root directory.
    – Seamus
    Commented Jul 29, 2021 at 19:35

2 Answers 2

0

I am not sure I follow but "/" is the root directory. Google says " /root is a standard first-tier directory in the root directory (as are /bin, /boot, /dev, /etc, /home, /mnt, /sbin and /usr). The root directory is the top level directory on any Unix-like operating system, i.e., the directory that contains all other directories and their subdirectories." I checked on my system and that holds true. I never allow the root to be shared, other directories yes but never the root. The directory you want to map has to be shared on either windows or linux so the other can find it.

0

I looked at some permissions and on the Pi it seems I needed to use pi as root.

This was the Windows 10 Map Network Drive

     \\192.168.1.xxx\pi\DirectoryName

And this is the share in Samba

      [DirectoryName]
         comment=Raspberry Pi Share
         path=/DirectoryName
         browseable=Yes
         writeable=Yes
         only guest=no
         create mask=0777
         directory mask=0777
         public=no

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.