0

I am setting up a "kiosk" mode display but Im having a hard time getting chromium to show properly on raspbian login. If I comment the line out, and manually start chromium, it will show. If I start using various different startup arguments in /etc/xdg/lxsession/LXDE-pi/autostart chromium starts but no window shows. How do I know? ps aux | grep chromium shows it's started up. If I try to open a browser after that, it will just say "opening in existing browser session" which is obviously also a problem because the existing browser session isn't showing.

I am guessing that it has something to do with the "restore pages" dialogue box, because if I start chromium manually, without any autostart scripts, it will ask me if i want to restore pages. But, I'd assumed --disable-restore-session-state flag would have taken care of that. I did find another threat that mentioned I should flag the opening address with --app but that also didn't work. Here are variations of what I've tried in my autostart script...

@chromium-browser --start-fullscreen --ignore-certificate-errors --disable-restore-session-state -http://127.0.0.1
@chromium-browser --start-fullscreen --ignore-certificate-errors --disable-restore-session-state ---app=http://127.0.0.1
@chromium-browser --kiosk --app=http://127.0.0.1
@chromium-browser --kiosk http://127.0.0.1
0
@chromium-browser --kiosk --force-device-scale-factor=2.0 --user-data-dir=/home/pi/.config/chromium-display1 --app=https://[first site]
@chromium-browser --kiosk --force-device-scale-factor=1.0 --user-data-dir=/home/pi/.config/chromium-display2 --window-position=1921,0 --app=https://[second site]

works for me. I am using it for two different displays so you can remove the second one if you don't need it.

1
  • That's essentially the same as what I'd already done @chromium-browser --kiosk --app=http://127.0.0.1
    – addohm
    Aug 2 at 13:40
0

I was able to get this to work by adding the --app-auto-launched flag to one of my previously mentioned entries.

@chromium-browser --kiosk --app-auto-launched --app=http://127.0.0.1

Reference link: https://peter.sh/experiments/chromium-command-line-switches/#app-auto-launched

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.