1

I have spent a lot of time looking for a solution to my problem. Everything I've tried hasn't worked so far.

From what I understand, this is an internet connection problem or a DNS issue. I followed this tutorial to setup Ubuntu Server on my new Raspberry Pi 4. I'm using wifi and Ethernet just to be sure.

Some have suggested to add nameserver 8.8.8.8 in /etc/resolv.conf. Not only it doesn't work, but every time I sudo reboot, the file content turn back to initial.

I even tried sudo ufw allow out 53,113,123/udp. No positive result.

Does anyone have an other idea that can help me solve this problem ?

3
  • 1
    Ubuntu Server uses Netplan (and cloudinit) to manage network settings, you shouldn't tamper with the config files manually.
    – tttapa
    Aug 3, 2021 at 23:25
  • @tttapa This issue persists even without tampering with network config files. I'm connected via ethernet and I still have this issue. It seems like Ubuntu doesn't setup ethernet correctly in the default case? Another Pi on the same switch (different OS) can connect fine.
    – weberc2
    Oct 15, 2021 at 15:51
  • I should also add that the same hardware was able to access the Internet just fine with a different image (same SD card, same Pi, same cables, same switch, etc). Also, strangely while the Internet doesn't seem to work, I can ssh in from LAN.
    – weberc2
    Oct 15, 2021 at 15:59

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.