0

I’m getting ’kernel panic’ when I try to use apt (or apt-get) to install a package or update/upgrade; I’m using a Raspberry Zero W with the latest version of Raspberry Pi OS available on their website (installed a few days ago).

Photo of error:photo of error

I’ve reinstalled multiple times, but it doesn’t work (I’ve tried DietPi, RPi OS, RPi OS Lite, but they all boot and work fine until I try using apt)

I couldn’t find anything on the internet about this specific problem either.

Is there any way to fix this?

If not: Is there any other way to at least be able to easily install software without apt?

6
  • 1
    It looks like it's related to network IO, are you able to perform pings or ssh to remote systems? Can you post the exact version of the kernel too? Has the pi zero worked before? Aug 5 at 13:31
  • It does look like possible hardware failure related to networking.
    – goldilocks
    Aug 5 at 17:35
  • I always wonder why error messages can't be more informative. Scanning through your photo, I see references to softirq which seems to suggest something in the networking chain is broken. Perhaps it's a network hardware failure (most likely IMHO), or a bad microSDC card. Have you tried replacing it?
    – Seamus
    Aug 5 at 21:41
  • @Seamus MicroSD problem was a friend’s thought as well. I can’t really replace it ATM though…
    – Auniverse
    Aug 6 at 17:02
  • @SEWTGIYWTKHNTDS The Pi has worked before; I’ve used it quite a bit. Pings work, but haven’t tried SSH. How do I find kernel number?
    – Auniverse
    Aug 6 at 17:14
2

Encountered the same kernel panic error on my 0W, also while doing an apt-upgrade but I suspect its just the amount of network traffic generated by apt-upgrade that causes it, not apt. This occurs from a fresh Raspbian install, both lite and full desktop versions. I had to disable IPv6 by adding "ipv6.disable=1" to the end of /boot/cmdline.txt . After rebooting, It's working without issue. Hope this helps!

1
  • Exact same issue for me and this fixed it. Thank you! Auniverse, Please set as answer if this fixed for you also.
    – Waddas
    Oct 19 at 21:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.