When I run the command vcgencmd measure_temp to measure the tempearture of my Raspberry Pi, instead of expected output (e.g. temp=50.1'C) it sometimes throws an error as follows:

vc_gencmd_send returned -1
vchi_msg_dequeue -> -1(22)

It is impossible to even google this to find out more. Can you please advise why this happens and how to prevent it? I have Raspberry Pi 4.

  • 2
    Does this answer your question? vcgencmd measure_temp doesn't always work
    – Seamus
    Commented Aug 14, 2021 at 17:17
  • Only partially, since it looks like and error and the suggested answer provides only a workaround. I would like to understand why this problem occurs at all, what triggers it. More importantly, it seems to me that this vcgencmd behaviour is accompanied by other problems (such as disfunctional recording via CSI camera) and can only be solved by reboot.
    – petervanya
    Commented Aug 19, 2021 at 8:55


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.