0

I've been using a RPI0W as a server for a while now, but an upgrade was getting necessary. So... I bought another RPi4 (Because the PI1 and PI2 that I still had laying around weren't much of an upgrade), plugged it straight into my switch (because this is another advantage: I don't have to connect my server over wifi anymore), and plugged in the power. According to what I read on google, there should be no issues when moving an SD card from one Pi to another (as long as the OS is recent enough to support the Pi's CPU).

At first it didn't work, but I quickly figured out because my static IP was still set on the wlan0 instead of eth0. Changed that, still doesn't work. Let's disable the static IP altogether and try again? Still nothing...

I put the card back in to the 0W and it still works. I took a different SD card and flashed a fresh raspbian on it. The only thing I changed was place an ssh file in the boot-partition.

When plugging it it, I can see it getting an IP in the lease-table of my router (always 192.168.88.205). However, nmap doesn't detect it. Also pinging to this IP gets no response. Neither does SSH work.

I also tried wireless but this worked even less: didn't get an IP.

Maybe I got a DoA? Luckily I still had some Pi4`s laying around from work. I swapped the Pi, and it still doesn't work...

So... the problem is not in the image, the problem is not in the settings, the problem is not in the SD-card, the problem is not in the network. That leaves only one option: the problem is in the user! (A classic PEBCAK problem)

I'm doing something wrong here. Anyone who can guide me in the right direction?

8
  • 1
    have you tested the lan cable?
    – jsotola
    Aug 16 at 23:51
  • @jsotola I tried a 2nd cable in a 2nd port of the switch. Didn't make a difference. (note that my workstation is also connected to this switch, so it work just fine) Also: if the cable is bad, would it be able to get an ip from DHCP?
    – Opifex
    Aug 17 at 0:14
  • @jsotola Oh my god, wait... I guess I did swap the cables but forgot to retest it. I did so now, and I receive pings just fine and can even SSH! So it was the cable after all! Still... any clue why I did receive an IP, but wasn't able to ping because of a bad cable? How does that work? If you can write an answer that explains it, I will accept yours. (Because otherwise I'd have to answer my own question by saying "The cable was faulty", which isn't really useful for anyone in the future...)
    – Opifex
    Aug 17 at 0:19
  • my guess would be that the cable has an intermittent connection ... perhaps the connection is good when partially plugged in ... that way, the IP was obtained as the cable was being plugged in ... check the cable end for damage and for foreign material ... the grooves in the cable end may be squished so that the contact wires in the socket do not touch the metal contacts in the cable end
    – jsotola
    Aug 17 at 0:28
  • @jsotola No damage or foreign material visible. It looks brand new. Bad connection is unlikely, because I unplugged and replugged several times.
    – Opifex
    Aug 17 at 0:32
0

With the information supplied it is impossible for anyone to definitively answer, but you have already determined the cause of you problem i.e. an inadequate cable.

ethtool eth0 would provide some useful diagnostic information.

All Pi before the 3B+ & Pi4 supported 10baseT/100baseT the later added 1000baseT (aka Gigabit Ethernet).

10baseT/100baseT work over 2 pair (a traditional Ethernet cable.
1000baseT requires a 4 pair/8 wire cable.

Unfortunately (due to a failure of the standards) negotiation of speed works over the basic 2 pair, but 1000baseT will not work without a fully functional 4 pair cable.

I suspect that the IP address negotiation works over the basic 2 pair, but actual data exchange will fail without a fully functional cable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.