0

When I boot the Pi, the Wifi symbol is greyed out and when I click on it, it says Wifi is disabled. I enable it and it works fine.

I can unblock everything with rfkill and everything is fine, but this is not a permanent solution.

What I've tried:

  • Add rfkill unblock all to /etc/rc.local, ~/.xinitrc.
  • Make a script unblock.sh with the same content and add it to /etc/init.d
  • Purge rfkill (it is still active afterwards plus I can't unblock anymore
9
  • What Bullseye upgrade?
    – Milliways
    Commented Aug 18, 2021 at 9:24
  • Well I changed the apt/sources.list entries to bullseye and upgraded
    – neolith
    Commented Aug 18, 2021 at 9:42
  • 3
    Is this an official Pi OS release? Have you asked over in the forums on raspberrypi.org? If I had to guess, the bugs haven’t been ironed out for the Pi yet. Commented Aug 18, 2021 at 11:48
  • Yes, it is, but I haven't asked in the forums yet.
    – neolith
    Commented Aug 18, 2021 at 12:55
  • Edit in the output from systemctl list-units | grep rfkill.
    – goldilocks
    Commented Aug 18, 2021 at 16:37

1 Answer 1

2

Bullseye is not yet released, even though the packages have been already pushed to the repo on 14.08. It's expected that not everything will work right away.

Note that you should have used apt-get dist-upgrade, not regular apt-get upgrade when switching to a new release. There's also an upgrade script you can use.

Also note that the correct syntax is

rfkill unblock all

, not

unblock rfkill all
6
  • The question is not really about Bullseye. dist-upgrade did not work because of The following packages have unmet dependencies: libc6-dev : Breaks: libgcc-8-dev (< 8.4.0-2~) but 8.3.0-6+rpi1 is to be installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    – neolith
    Commented Aug 18, 2021 at 12:54
  • that upgrade script ... hmm .. if you have 64bit kernel enabled, but 32bit userland - it won't work as far as I can see
    – Bravo
    Commented Aug 19, 2021 at 2:10
  • 2
    I did a dist-upgrade now. It doesn't solve the issue
    – neolith
    Commented Aug 19, 2021 at 13:33
  • @Bravo You can run a 32-bit userland with a 64-bit kernel, but you can't run a 64-bit userland with a 32-bit kernel.
    – goldilocks
    Commented Aug 19, 2021 at 15:16
  • 1
    @goldilocks - I do know that - I was talking about that upgrade script - it will attempt (and should fail) to change apt sources to point to debian repos for aarch64 - because, running 64bit kernel uname -m outputs aarch64 - and the script assumes wrongly that you want 64bit OS - but thanks for the uncorrection
    – Bravo
    Commented Aug 19, 2021 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.