0

My headless Pi Zero W gives a segmentation fault whenever I run the ExpressVPN application. This problem occurs on a brand new Sandisk Ultra microSD card, imaged with Raspbian Lite 32 bit via the Raspberry Pi Imager for Windows. ExpressVPN downloaded with wget and installed successfully with dpkg.

The Pi worked fine for about a month on a previous project, until there was an unsafe shutdown or two or three, at which point apt get upgrade began producing segmentation fault. I reimaged that original microSD card several times but the issue recurred.

I got a new microSD card after reading this post which suggests that unsafe shutdowns corrupt the filesystem and cause a segmentation fault. Unfortunately, the new microSD card with a new Raspbian image produces the same error. Although the microSD card is new, I'm using the same microSD to SD adapter for imaging on Windows.

This post suggests a reliable power supply may be the problem. Currently I'm using a 5.1V/1A CanaKit power supply, which seems more than adequate according to these figures. On the previous project when the unsafe shutdowns occured, I used a microUSB to USB cord with a USB cellphone-type wall adapter. I don't have it anymore and don't remember the amperage. I doubt that's what fried it but I suppose its a possibility since I know nothing about electricity.

Did I completely fry my Pi with one too many unsafe shutdowns and a random power supply? Is it possible the microSD to SD adapter is the culprit? If a brand new SD card returns the same problem, do I need to move on to a brand new Pi? If so, how do I prevent these problems from occurring in the future?

Additionally, I did another reimage with Balena Etcher, same segmentation fault on executing ExpressVPN. Also tried the NordVPN app, same segmentation fault.

7
  • "a reliable power supply may be the problem" -> You should check the system logs: sudo grep "Under-voltage" /var/log/syslog*
    – goldilocks
    Aug 20 at 16:03
  • no result so that's not the issue. good to rule it out! Aug 20 at 19:07
  • I wouldn't say it rules it out, as this is a bit dependent on the operation/configuration of the logging system.
    – goldilocks
    Aug 20 at 20:17
  • OK, any other keywords to grep for? I tried "voltage" and "power" and didn't see anything. As far as the logging system its a fresh Raspbian / Debian Buster with the latest updates Aug 20 at 20:36
  • I also just tried using a 5V/2.4A output charger, same error Aug 20 at 21:05
0

There is nothing on the Pi to damage! To damage a Pi you have to supply excessive voltages or mechanically damage it.

Unsafe shutdown CAN damage a filesystem, but the risk is much overrated in 8 years with 20 SD Cards and more Pi than I care to admit I have never encountered this. I have 4 Pi running at the moment, and they have survived many power outages.

A segmentation fault is generally caused by a corrupted image, although it is possibly faulty RAM this is unlikely.

Faulty software can damage files.

The PiZero is (IMO) a poor device; it has inadequate memory and poor build quality, with vulnerable connectors hanging over the edges of the board. You could certainly benefit from a regular Pi.

3
  • What faulty software might be at play here? It's all completely new and up-to-date, the OS, the software, even the microSD card. The Pi itself is less than a year old and was only used daily for about a month. I'm inclined to believe the PiZW is a lemon, I've been troubleshooting this off and on for 6 months Aug 20 at 21:15
  • Well, you can never completely rule out malware type stuff when you have problems for which you have no definitive cause. As per my other comment, IMO it is most likely defunct/damaged/defective hardware, but you don't have the means to confirm that. So, again, I'd start with another Pi (and as Milliways says, consider upgrading, the 3A+ is a nice one for zero type roles). If you have the problem then, it's either malware, or some sneaky bug.
    – goldilocks
    Aug 20 at 21:34
  • OK! Thank you both Aug 21 at 6:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.