This question already has an answer here:

Still trying to parse this:

https://raspberrypi.stackexchange.com/questions/10251/prepare-sd-card-for-wifi-on-headless-pi

I have Mac laptops (older 2008 Macbook and MBA 2011) that I'm trying to use to preconfigure my Model A Pi Raspbian (w/ Edimax wifi dongle) so the Pi can get on my home wifi the first time it boots and i can ssh into it.

I don't have a spare kb, monitor, mouse at home.

Is this possible?

marked as duplicate by goldilocks, lenik, syb0rg, RPi Awesomeness, Impulss Feb 6 '14 at 0:49

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Is this possible?

If that's your question, the answer is yes, although that is clear in the Q&A you link to -- which goes a little bit further in terms of asking how is this possible, and has an accepted answer already. If that answer does not work for you, feel free to reference it in a more specific question, detailing what you actually tried to do and what specific problems you had.

If you are not familiar with the general format of Stack Exchange, of which this Raspberry Pi site is a part, you might want to familiarize yourself via the tour (also accessible via "help" in the top bar). It is NOT a forum, meaning, the paradigm is NOT to introduce a topic on which you are seeking some input, have someone reply to you, then you respond to them, and a dialogue ensues. Instead, the goal here is to present questions (again specific questions) -- in as polished and well thought out manner as you can -- and then receive definitive, conclusive, specific answers. Not open ended dialogue.

Which is not to say there is anything wrong with forums and open ended dialogue, but there is already a raspberry pi forum, and this is not it. Part of what's at issue with your particular question is that, as you yourself point out, it has already been answered, and an explicit goal of the Stack Exchange format is to avoid repeated discussion of the same topics over and over again.

So, do your best with the information already available, and if you find specific points unclear, then feel free to add to the available information by asking about them, rather than obliquely asking for a re-hash ;)

  • I understand that I need to edit the wpa_supplicant.conf file, but I don't understand how I'm supposed to access it on my OS X machine. In the OS X finder I've tried to access via Finder by trying: /Volumes/boot/etc/network/interfaces to no avail. – cfarivar Jan 19 '14 at 22:50
  • 1
    There are 2 partitions on the SD card. The second one is an ext4 partition, and that contains /etc. OSX is not by default ext4 friendly, and this is a problem you must solve -- fortunately, the question "How can I access an ext4 filesystem from OSX?" is also one which has been asked and answered before. – goldilocks Jan 20 '14 at 2:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.