0

I've been experimenting with Squeak on my Pi and have got it up and running following these instructions: http://www.raspberrypi.org/forum/viewtopic.php?f=34&t=9046

However, I can't get the sound working. This produces nothing:

FMSound bass1 play.

Sound does work using Scratch, which uses Squeak (although a different image presumably).

  • Following the instructions to get to the image in Scratch and open a Workspace here raspberrypi.stackexchange.com/a/5168/12203, the above play command does work. However, this is a very old version of Squeak, it would be good to see this work in 4.3 or 4.4 – Eric Clack Jan 19 '14 at 20:04
0

Squeak needs to be started using the flag -vm-sound-alsa

E.g.

squeak -vm-sound-alsa /usr/share/Squeak4.4.image

When you run Scratch on the Pi it calls squeak from a bash script and that passes this flag, which explains why sound works in Squeak.

The Squeak entry in the Programming menu doesn't contain this flag.

Thanks to Tim Rowledge for the answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.