0

I have my RetroPie EmulationStation set up to be 40% volume which makes for some good game volumes on my Picade's speaker. However, for the game snaps, I cannot hear the audio at all.

When I look at the parameters based to omxplayer using ps -fp <pid of omxplayer.bin>, I can see it's passing values like "-4000" for "--vol", which is just too quiet (experimenting and "-1000" sounds about right and equivalent to the in-game volume generated by the 40% setting)

If I push the main volume up to 75%, omxplayer is fine but then the game volume is far too loud.

Does anyone know how I can override the values being passed to omxplayer.bin independently of the main game volume EmulationStation?

Thanks

1 Answer 1

0

Well, no sooner do I ask this question than I come across a solution that works.

  1. By settings the EmulationStation volume to 75% (so snaps play well)
  2. Modify /opt/retropie/configs/all/runcommand-onstart.sh to have the line amixer set PCM 40%
  3. Modify /opt/retropie/configs/all/runcommand-onend.sh to have the line amixer set PCM 75%

Ideally wouldn't need to do this though. Maybe there is something I'm missing?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.