I seem to be one of countless scores of people who just don't seem to have the magic touch in getting this little machine to actually run. I will walk through the history of what I have done.

Model B, Emtec 4GB SD card class 4 (on the wikipedia approved list of RPI SD cards), yellow VGA cable to a television. I formatted the card with Windows 7 and copied the Raspbian net installer files on, tried to boot, nothing but a red light.

Flashed the card with flashnul, reformatted with SDFormatter this time, copied the files, same thing. Repeated the steps of the last sentence with a second SD card that is exact same make and model. Same thing.

Took voltimeter and tested power supply, showing less than 5v, charger is rated for 1000mA.

Repeated the flash/format step again, installed NOOB's thinking it would be so easy a child could do it. IT BOOTS! Install Arch, restart, IT IS ARCH! COOL! Follow the wiki steps on setting up Arch, run the pacman updates, system updates itself fine, pull power, wait 20 seconds, plug back in... it took 2 hours to boot complaining about persistent journal or some such nonsense. It goes into error mode, so I check and the pacman database is corrupted. I try to man pacman and learn more about it but I get errors. I eventually give up trying to repair Pacman installation and decide to flash/format again this time with a different download of Raspbian Installer on the Raspbian.org website, the one that says it is abandonware and that we shouldn't use it but they still strangely have a link to it?

Well trying to flashnul the card this time gave me Access Denied errors on various sectors... sigh... I reboot my desktop and this time flasnul works, reformat with SDFormatter, copy the Raspbian installer boot files, try the Pi, again nothing but the dreaded red light.

I must be missing the secret sauce to get this blasted contraption to actually work correctly. I was hoping that I could use this to teach children about computers and introduce them to Scratch but I feel like I must be doing something wrong. Clearly I am not alone, the internet is flooded with people who struggle just getting it to boot. It is like trying to pick fly poop out of pepper while wearing boxing gloves! Why is it so hard? Did I get a defective one? (NOTE: it is a UK model, blue audio jack).

  • Just so people know how this went for me, the SD card was indeed defective and stopped working altogether eventually. I have since switched to a Duracell Micro SD with SD card adapter and it works infinitely better. Commented Oct 9, 2014 at 10:40

3 Answers 3


I understand your frustration, but there is one caution in your post "system updates itself fine, pull power, wait 20 seconds, plug back in". NEVER turn off the power on ANY computer without shutting down properly.

For Linux this is sudo shutdown -h now (or similar).

Shutting down may damage the filesystem, and from reports on this Forum the SDcard on the Pi seems to be more prone to this (although I have never experienced problems).

It seems your Pi is probably OK - it did work.

I would suggest that you try again with a new SD card (they are cheap enough). Install Raspbian. I won't try to repeat instructions here (I don't use Windows), but there are guides on the web and @goldilocks has indicated one way. Look at http://elinux.org/RPi_Easy_SD_Card_Setup

For troubleshooting http://elinux.org/R-Pi_Troubleshooting#Power_.2F_Start-up

A couple of other points. You mention "yellow VGA cable" I assume you are using the RCA output to your TV. It is easier if you can use hdmi, but it is possible to get RCA working with a little care (and it should be automatic).

One final point. You stated "Took voltimeter and tested power supply, showing less than 5v, charger is rated for 1000mA". Less than 5V is OK, but less than 4V75 is not. Many mobile phone chargers are unsuitable, as, even though they can supply sufficient current, the voltage is too low. If you have an Apple power supply this should be OK, and many others are, but later model smart phone chargers, designed to rapidly charge high capacity batteries are not.

  • Hi Milliways, I accepted your answer as I discovered on my second attempt at Arch that you were indeed correct. Simply because the pacman update command had finished and there were no more processes running for my user didn't mean that it was safe to pull the power. Since I have been using the shutdown command I have not had any additional problems! Still this worries me to leave my Pi running all day in the case of a power outage. Without a UPS it seems like it is very prone to corruption. That is another matter entirely though. Thanks for your help! Commented Jan 22, 2014 at 20:23
  • My Pi runs continuously. I am not too worried about power outages (I have had a few - mainly caused by leaky capacitor start motors). When the Pi is doing nothing, there is much less likelihood of pending disk activity. Most disk problems should be fixed by journalling on restart.
    – Milliways
    Commented Jan 22, 2014 at 23:08

This does seem to be a frequent problem :( It's hard to say that it isn't a defective board, because I'm pretty sure there are ones out there with legitimate SD card reader issues (they can't all be perfect, and there are millions of them now) and this is probably one of the first places people with problems will show up.

One of the commonalities though, is that no one ever seems to have tried the one method that seemed the simplest and easiest to me -- the Raw Images method from the rpi.org download page -- perhaps because it requires a linux machine1 and is described there as "intended for advanced users". This is a little bizarre because it's much simpler than the other methods I've seen described various places. Of course, that might not be clear since it's not described there at all.

  1. Download an .img file. The ones on the download page are zipped, or gzipped, or tarred, or whatever. Find an appropriate way to un-zip/gzip/tar/whatever it so you have somekinda.img -- it's just one file, probably 2-4 GB in size.

  2. Insert your SD card. Do NOT bother formatting it with anything. If it is already formatted, you'll likely notice in addition to the device node -- e.g., /dev/sdb -- there will be at least one partition, /dev/sdb1. In any case, it doesn't matter; I mention this because you want to copy onto the device, not a partition, so you need to recognize the difference. The device's node does not have a number at the end; /dev/sdb, not /dev/sdb1. If there is no sdb1, don't worry. If you've never used linux before, it won't necessarily be sdb, so figuring this out is probably the hardest part (leave a comment and I can explain further -- DO NOT guess and accidently trash your hard drive, lol). All you need is the device node. Then:

     dd if=somekind.img of=/dev/sdb bs=512

You'll need privileges for that (e.g., via sudo). That will take a few minutes. When it's done, it's done, just put it in the pi and plug in the power (which reminds me, in case this wasn't made clear anywhere -- don't be sticking the card in and out while the pi is plugged in).

You could also check that everything worked first by mounting the partitions.2 You might have to take the card out and put it back in for them to be recognized. There should now be two partitions on the device, so if it was sdb, there's now an sdb1 and a sdb2 as well.

> mkdir boot; mkdir root
> mount /dev/sdb1 boot/; mount /dev/sdb2 root/

Again, you'll need privileges. The first partition will be a small vfat one with a handful of files including kernel.img and config.txt. The second one will be a much bigger ext4 one with an extensive filesystem hierarchy on it.

1. Actually, it just requires dd, which is available for OSX, and Windows via Cygwin. You could also do this using a linux live CD or VM.

2. This part will be harder without a linux system since windows and OSX do not play nice with ext4 filesystems. Also note that what I've described there applies to the normative linux distros and probably not RISC OS and some other things, although the install via dd should work with any of them.

  • Thank you, I have a linux machine, but my SD card reader is on my Windows machine and is integrated in the motherboard. It is an odd desktop model. I am guessing that a linux live CD is the way to go, unless you can think of a way that I can create the proper partitions and unpack the .img file on a Windows machine? Commented Jan 20, 2014 at 22:24

RCA output is disabled as default configuration.

You must to edit /boot/config.txt file in your SD card and comment out:


reboot and be happy.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.