0

Note: I have added additional links to the end of the question as I don't have enough points to use actual links.

I'm trying to use the Adafruit Tiny Thermal USB printer [UK Link] [US Link [A]] with Raspberry Pi OS but I am having a few issues. I am connecting the printer via USB.

I have looked at a few tutorials mainly This one but also [B] and [C]

Following the main tutorial, I was unable to get any of the echo commands working at the start as I kept getting Permission denied warnings.

But, I skipped to [Commence Major Installation!] [D] section and I have been able to set up the printer and at least print something.

The set up process was however different than the tutorial. The tutorial lists it as USB Serial Port #1 with options for baud rate etc. But for me, it listed as Unknown with no options available.

Screenshot of printer installation dialogue

I was able to set up the printer this way using the Zijiang brand (as the tutorial suggests). After set up, the device URI is shown as: usb://Unknown/Printer. And I was able to print something at least, using the Print Test Page button:

Screenshot "Print Test Page" button

This comes out as:

Printed result with incorrect characters

As you can see, the text becomes corrupted. Printing text with the echo "This is a test." | lp command also produces random corrupted text, but at least it prints something.

Images do work mostly. Using the command lp -o fit-to-page /usr/share/raspberrypi-artwork/raspberry-pi-logo.png, this comes out as:

Printed result with incorrect characters and correct image

The top of the image becomes random characters, but most of the image prints fine.

I have tried this with various images and each one starts off printing random characters and eventually prints the rest of the image correctly.

Any ideas what to try to fix this? Is this something to do with the baud rate? (The printer came with a receipt listing the baud rate as 9600).

Additional Links:

[A] https://www.adafruit.com/product/2751

[B] https://learn.adafruit.com/mini-thermal-receipt-printer

[C] https://learn.adafruit.com/instant-camera-using-raspberry-pi-and-thermal-printer

[D] https://learn.adafruit.com/networked-thermal-printer-using-cups-and-raspberry-pi/connect-and-configure-printer#commence-major-installation-2552734-14

1 Answer 1

0

For anyone else having similar issues with the USB version:

I was able to get it working using a Raspberry Pi 4 instead of Raspberry Pi OS on a computer.

The fact that the set up process is different to the tutorial doesn't matter, it can still work.

I could still not get the echo commands working at the start of the tutorial due to the same permission issues. So I'd suggest also skipping them. The rest worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.