1

I have a NetGear modem/router (2.4G) connected with a TP-Link AX1800 Wifi 6 router (2.4g and 5g networks) connected to it with an ethernet cable.

I tried connecting my Pi (headless) to the 2.4g TP-Link Network and couldn't get it to work using Raspbian with a wpa_supplicant.conf & blank ssh on /boot/ and then trying PiBakery. When I plug the SD card back into the laptop the wpa_supplicant and ssh files disappear appropriately so it's booting. I also tested using an HDMI and monitor so Rasbian works but the wifi doesn't for some reason.

All of my home devices are connected to the TP-Link router no problem. Is it possible that the NetGear router being chained to it is causing an issue? It still has an old 2.4G ssid running on it with a different name than my TP-Link 2.4G ssid. All networks are not hidden. Not sure if that would somehow cause any issues.

I tried researching and googling and couldn't find an answer. I'm out of ideas on why my pi can't connect to the network...thoughts?

Here's my supplicant if anyone's curious but i dont think that's causing the issue:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=us

network={
    ssid="TPLink2.4G"
    psk="password123"
    key_mgmt=WPA-PSK
}

I also tried:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=US

network={
    ssid="TPLink2.4G"
    psk="password123"
}
1
  • DHCP server isn't showing the Pi on my TP-Link router settings
    – user138962
    Commented Sep 7, 2021 at 1:40

2 Answers 2

1

A Raspberry PI network configuration guide is here

https://www.raspberrypi.org/documentation/computers/configuration.html#configuring-networking31

Troubleshooting tips

  • Double-check that the file was written in plaintext, with no special characters.
  • Double-check that the file has disappeared from your boot directory.
  • Connect the Pi to a TV or monitor via HDMI to make sure it’s booting normally.
  • If you’re employing a Raspberry Pi Zero W, confirm you’re attempting to attach to a 2.4GHz network (the Zero doesn’t support 5G).
  • If you’re employing a Raspberry Pi Zero, confirm it is a Raspberry Pi Zero W, not a basic Zero (only the W supports wifi and Bluetooth). The version and the model are on the PCB.

Another problem that unfortunately affects some versions of Raspbian/Rasperry Pi OS is that the rfkill status of the Wi-Fi interface is not unblocked so the wifi doesn't connect. This can be checked by logging in on the console and running:

rfkill

For the Wi-Fi to work it should show that the wlan0 device is unblocked in the the SOFT and HARD colums. If the device isn't connecting due to this issue then it will show as blocked in SOFT column.

This can only be remedied by mounting the image and changing the config as per this question, or by booting it and logging in on the console and typing:

sudo rfkill unblock wifi
1

I have this issue often, from what i observed so far these things help most- 1)disable bluetooth 2)use new wpa supplicant file 3)setup wifi with sudo raspi-config, and safely reboot

these things happen on my pi4, pi3, pi zero w and w2... i sometimes need to switch between 2 networks, and problem usually happens after i want to switch to new one. Setting it up in window manager often does not work...

my sample wpa i use for every pi:

country=sk

update_config=1

ctrl_interface=/var/run/wpa_supplicant

network={

scan_ssid=1

ssid="ssidname"

psk="ssidpw"

}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.