-1

I have a python script that turns the camera into a webcam. Today I did an upgrade:

Get:1 http://archive.raspberrypi.org/debian bullseye/main armhf libc6-dbg armhf 2.31-13+rpt2+rpi1 [6377 kB]
Get:2 http://archive.raspberrypi.org/debian bullseye/main armhf libc-devtools armhf 2.31-13+rpt2+rpi1 [245 kB]
Get:3 http://archive.raspberrypi.org/debian bullseye/main armhf libc6-dev armhf 2.31-13+rpt2+rpi1 [1813 kB]
Get:4 http://archive.raspberrypi.org/debian bullseye/main armhf libc-dev-bin armhf 2.31-13+rpt2+rpi1 [266 kB]
Get:5 http://archive.raspberrypi.org/debian bullseye/main armhf libc6 armhf 2.31-13+rpt2+rpi1 [2297 kB]
Get:6 http://archive.raspberrypi.org/debian bullseye/main armhf libc-bin armhf 2.31-13+rpt2+rpi1 [682 kB]
Get:7 http://archive.raspberrypi.org/debian bullseye/main armhf bluez armhf 5.55-3.1+rpt1 [843 kB]
Get:8 http://archive.raspberrypi.org/debian bullseye/main armhf libc-l10n all 2.31-13+rpt2+rpi1 [863 kB]
Get:9 http://archive.raspberrypi.org/debian bullseye/main armhf locales all 2.31-13+rpt2+rpi1 [4084 kB]
Get:10 http://archive.raspberrypi.org/debian bullseye/main armhf libraspberrypi-dev armhf 1:2+git20210719~113532+97bc818-3 [180 kB]
Get:11 http://archive.raspberrypi.org/debian bullseye/main armhf libraspberrypi-doc all 1:2+git20210719~113532+97bc818-3 [1564 B]
Get:12 http://archive.raspberrypi.org/debian bullseye/main armhf libraspberrypi-bin armhf 1:2+git20210719~113532+97bc818-3 [40.8 kB]
Get:13 http://archive.raspberrypi.org/debian bullseye/main armhf libraspberrypi0 armhf 1:2+git20210719~113532+97bc818-3 [177 kB]

After rebooting, now when I run the script, I get

picamera.exc.PiCameraMMALError: Failed to create MMAL component b'vc.camera_info': Function not implemented

To reiterate: Nothing changed other than the upgraded list of packages above. Which one broke the camera and how do I fix it?

I un- and re-installed picamera, and that was no help. There is no conflicting version that I can find:

Python 3.9.2 (default, Mar 12 2021, 04:06:34) 
[GCC 10.2.1 20210110] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> from pkg_resources import require
>>> require('picamera')
[picamera 1.13 (/usr/lib/python3/dist-packages)]
>>> require('picamera')[0].version
'1.13'
1
  • 2
    Some reported that sudo mv /opt/vc /opt/oldvc; sudo apt-get install --reinstall libraspberrypi0 libraspberrypi-dev libraspberrypi-doc libraspberrypi-bin solved the "function not implemented"-problem. Sep 11 '21 at 10:58
1

Raspberry Pi's camera interface stack has changed in the Bullseye version of Debian/Raspberry Pi OS. In short, it's moving to line up with standard Linux APIs (V4L2 and libcamera). More information can be found here: https://www.raspberrypi.com/news/bullseye-camera-system/

1
-2

This appears to be a bug in the version of libraspberrypi0 that was installed in the upgrade. Manually downgrading to libraspberrypi0_1.20210831-1_armhf.deb fixed it.

EDIT: This has been confirmed as a bug in libraspberrypi0.

https://github.com/raspberrypi/userland/pull/714

It is fixed in libraspberrypi0 1:2+git20211125~155417+14b90ff-1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.