0

After startup my RPI synchs to the correct date, but the time remains about 90 minutes off (behind). sudo ntptime gives:

sudo ntptime

ntp_gettime() returns code 5 (ERROR)
  time e4e82bc8.c2d92000  Sun, Sep 12 2021  9:33:28.761, (.761126),
  maximum error 16000000 us, estimated error 16000000 us, TAI offset 0
ntp_adjtime() returns code 5 (ERROR)
  modes 0x0 (),
  offset 0.000 us, frequency -8.808 ppm, interval 1 s,
  maximum error 16000000 us, estimated error 16000000 us,
  status 0x4041 (PLL,UNSYNC,MODE),
  time constant 7, precision 1.000 us, tolerance 500 ppm,

systemctl status ntp gives:

* ntp.service - Network Time Service
   Loaded: loaded (/lib/systemd/system/ntp.service; enabled; vendor preset: enab
   Active: active (running) since Sun 2021-09-12 09:21:20 CEST; 15min ago
     Docs: man:ntpd(8)
  Process: 5516 ExecStart=/usr/lib/ntp/ntp-systemd-wrapper (code=exited, status=
 Main PID: 5522 (ntpd)
    Tasks: 2 (limit: 4915)
   CGroup: /system.slice/ntp.service
           `-5522 /usr/sbin/ntpd -p /var/run/ntpd.pid -g -u 112:118

sep 12 09:34:32 raspberrypi-OpenCPN ntpd[5522]: Soliciting pool server 38.229.58
sep 12 09:34:38 raspberrypi-OpenCPN ntpd[5522]: Soliciting pool server 185.111.2
sep 12 09:35:36 raspberrypi-OpenCPN ntpd[5522]: Soliciting pool server 23.157.16
sep 12 09:35:36 raspberrypi-OpenCPN ntpd[5522]: Soliciting pool server 194.57.16
sep 12 09:35:37 raspberrypi-OpenCPN ntpd[5522]: Soliciting pool server 2606:4700
sep 12 09:35:42 raspberrypi-OpenCPN ntpd[5522]: Soliciting pool server 162.159.2
sep 12 09:36:40 raspberrypi-OpenCPN ntpd[5522]: Soliciting pool server 216.229.0
sep 12 09:36:43 raspberrypi-OpenCPN ntpd[5522]: Soliciting pool server 2a02:2b88
sep 12 09:36:43 raspberrypi-OpenCPN ntpd[5522]: Soliciting pool server 78.202.24
sep 12 09:36:46 raspberrypi-OpenCPN ntpd[5522]: Soliciting pool server 185.89.20
lines 1-20/20 (END)

At the time of this check the actual time was 11:15 AM. Why does the time not sync correctly?

4
  • 1
    Is your timezone correct? Which OS/version? Or did you make any changes? PiOS doesn't use ntp service but systemd-timesyncd. For info you would use command timedatectl
    – Dirk
    Sep 12, 2021 at 13:27
  • Is there a particular reason that you have installed ntp instead of using RPi's default sntp? You may find this Q&A helpful - particularly some of the more current answers. And this Q&A may give you some useful background.
    – Seamus
    Sep 12, 2021 at 15:58
  • Timezone is correct, OS: Buster, latest upgrade. I disabled the default timesyncd and installed ntp service because I felt this a more generally used timeserver environment.
    – Erik84750
    Sep 13, 2021 at 14:14
  • Solved: removed ntpd and reinstalled systemd-timesyncd
    – Erik84750
    Sep 16, 2021 at 15:58

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.