I am trying to get ublox zed f9p module work with raspi 4. I am using this module

I am running on ubuntu 20.04 desktop version on raspi 4 and i have connected the module serially(/dev/ttyS0) to my raspi 4. When i do sudo cat /dev/ttyS0, I get stream of data initially but later I get this weird messages $GNTXT,01,01,01,NMEA unknown msg*46.

I am sure that i have done serial configurations correctly on raspi-config and my wiring is correct too(works in nano).

I have found in other threads running this sudo stty -F /dev/ttyS0 -echo solved problem for many but it didnot work for me. I have also tried disabling bluetooth but no luck.

also when i try to parse the data in python using serial.serial, i get the stream of data initially but then it throws input/output error.

i tried debugging it through dmesg but it doesnot show any error with respect to dev/ttyS0.

$ dmesg | grep /dev/ttyS0

[    0.000000] Kernel command line:  coherent_pool=1M 8250.nr_uarts=1 snd_bcm2835.enable_compat_alsa=0 snd_bcm2835.enable_hdmi=1 bcm2708_fb.fbwidth=640 bcm2708_fb.fbheight=480 bcm2708_fb.fbswap=1 smsc95xx.macaddr=DC:A6:32:8E:99:AC vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  net.ifnames=0 dwc_otg.lpm_enable=0 console=ttyS0,115200 console=tty1 root=LABEL=writable rootfstype=ext4 elevator=deadline rootwait fixrtc quiet splash
[    1.685255] printk: console [ttyS0] disabled
[    1.685287] fe215040.serial: ttyS0 at MMIO 0x0 (irq = 16, base_baud = 62500000) is a 16550
[    1.691208] printk: console [ttyS0] enabled
[  154.826729] ttyS ttyS0: 1 input overrun(s)

However the module works well if i connect it through usb. some insights on this would be helpful.

  • My experience is that using Windows newbie friendly Ublox U-centre starts up smoothly, while Rpi4B Linux CLI GPSS tools have a very steep learning curve. (1) electronics.stackexchange.com/questions/557417/… (2) electronics.stackexchange.com/questions/519711/…
    – tlfong01
    Sep 15, 2021 at 8:33
  • 1
    you reckon its the problem with power supply?
    – siddharth
    Sep 15, 2021 at 10:04
  • No I did not hint that power supply might be a problem. I think it is very unlikely. I noticed that you said USB works. This is a big tip. I would forget Rpi4B on board serial ports., and try USB serial port first. ubuntu 20.04 might also have a teething problem. I still recommend the evil guy Windows. NEO9 might have some tricks with Widnows, and they don't care about Linux. I did have a painful experience messing with CLI.
    – tlfong01
    Sep 15, 2021 at 13:23
  • 1
    ultimately were you able to figure out a solution for your ubuntu 20.04 and raspi4?
    – siddharth
    Sep 16, 2021 at 5:12
  • Well (1) Mine is Matek M9N: item.taobao.com/…, (2) I have been using Win10 Ublox U-centre and Rpi4B USB serial ports successfully. I have not tried ubuntu 20. So I am only suggesting some troubleshoot tricks.
    – tlfong01
    Sep 16, 2021 at 5:27

1 Answer 1


I finally managed to somehow figure out the solution for it. it was because of this [email protected] which was blocking any other data from ttyS0. Just do the following:

sudo systemctl stop [email protected]
sudo systemctl disable [email protected]

and you are good to go.

NOTE: This is only tested for serial port(/dev/ttyS0) in raspi 4B with ubuntu 20.04.
  • 1
    How nice you have found the way to go. Very good news for ubuntu fans.
    – tlfong01
    Sep 16, 2021 at 14:40
  • 1
    Thanks mate! hope the needy ones find this thread
    – siddharth
    Sep 17, 2021 at 5:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.