-1

I have installed windows 10 IoT core on my Raspberry Pi 3B and connect my raspberry pi and my pc to the same connection. but when I want to run a simple program written in Visual Studio 2022. these errors appears:

> Missing tools on -574456429: g++ gdb rsync zip
> Could not resolve path '~/projects/Blink1/obj/ARM/Debug/'.

the code:

#include <wiringPi.h>


// LED Pin - wiringPi pin 0 is BCM_GPIO 17.
// we have to use BCM numbering when initializing with wiringPiSetupSys
// when choosing a different pin number please use the BCM numbering, also
// update the Property Pages - Build Events - Remote Post-Build Event command
// which uses gpio export for setup for wiringPiSetupSys
#define LED 17

int main(void)
{
    wiringPiSetupSys();

    pinMode(LED, OUTPUT);

    while (true)
    {
        digitalWrite(LED, HIGH);  // On
        delay(500); // ms
        digitalWrite(LED, LOW);   // Off
        delay(500);
    }
    return 0;
}

enter image description here

.Windows 10 IoT core version is 10.0.17763.107

.Visual Studio version is 2022 preview

Any idea???

1

wiringPi is a Linux library.

Windows IoT is a Windows (like) environment.

The two are incompatible.

If you want to use the GPIO from Windows IoT you will have to use the methods provided by Windows IoT.

As far as I am aware Microsoft have stopped support for Windows IoT on the Raspberry Pi.

1
  • Thanks for your answer. yeah, I am aware that Microsoft has stopped supporting IoT core but in a project, I should use it. Even If I run a simple XAML program I have this error: imgur.com/S3XkoON
    – Pouya
    Sep 16 '21 at 9:36
0

I installed the Visual Studio 2017 Community version instead of the Visual Studio 2022 Enterprise version (Preview) then the connection problem was solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.