2

I did a fresh install of NOOBS on a 4gb SD card.

As soon as I did apt-get update && apt-get upgrade, I got an error with a message that there is "no space left on device". I thought that 4GB cards were sufficient?

I'm attaching some pictures of some diagnostics that I hope will make it obvious to the right person.

Other people who have had the same problem just needed to increase the size of their partition to the full disk by running sudo raspi-config. However, in my version of NOOBS that is not an option, and it says that it's already using the whole disk.

Thank youenter image description here

2

Your problem is NOOBS. This uses a primary partition (1447MB) which contains the images of the OS. All the remaining space is already in use. You will either need a bigger SD or ditch NOOBS and install Rasbian.

You could delete some of the images, and resize partitions, but this is rather involved, and would need to be done on another computer which can read the partitionss.

  • Thank you! So it's the extra operating systems that come in NOOBS? I'll try editing it in gparted on a linux machine and see if I can fix or ruin the card before starting over. – geneorama Jan 27 '14 at 4:16
  • I tried deleting the backup partition, but then I couldn't expand the other big partition to fill the newly unallocated space. It raised an error in gparted, then wouldn't boot. – geneorama Jan 27 '14 at 4:47
  • I'm confused why NOOBS says that you only need a 4GB card if that's not enough space. I don't see anything about deleting the extra files in their installation instructions. – geneorama Jan 27 '14 at 4:48
  • 4GB is enough - I have run this myself, but Raspbian had grown and after using 1.5GB for images (which have also grown) it doesn't leave much room. I am not sure which partition you have deleted. I would have deleted some of the images on the FAT16 partition, shrunk this, then expanded/moved the extended partition. – Milliways Jan 27 '14 at 5:12
  • Although you were not 100% clairvoyant, you definitely helped. I installed a fresh Raspbian using the advanced methods (silent install) in the NOOBS git page, and this helped. I don't know why I ran out of space doing the default install, or why the re-partition didn't work, but now I'm happily at 77% after a fresh install. Thank you!!! – geneorama Jan 27 '14 at 7:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.