0

I run RasperryPi OS on a Pi 4. I want to emulate/install TinyCore OS on a qemu virtual machine. I am not sure if my problem rely's on the underlying Pi4 hardware?

This is how I run the iso I downloaded from the tinycore website. I use Boot TinyCore. from it's bootloader menu.

#/usr/bin/env bash
qemu-system-x86_64 \
    -drive format=raw,file=tinycore.img \
    -m 1024 \
    -drive format=raw,file=TinyCore-current.iso,media=cdrom,readonly \
    -smp 2 \
    -nic user,model=virtio

The problem is a kernel panic. enter image description here

The last "normal" message I can see is

Booting Core 12.0
Running Linux Kernel 5.10.3-tinycore
Checking boot options... Done.
Starting udev daemon for hotplug support... Done.
Scanning hard disc partitions to create /etc/fstab...
Setting Language to C Done.
Possible swap partition(s) enabled.
Loading extensions...

I do not know why it happens and I do not know how to go deeper into diagnoses. What can I do here? After the kernel panic the VM reboots and it happens again.

I also tried Boot Core (command line only).. The bash shows up. But also then after some seconds a kernel panic appears.

Background of my question: I need to emulate TinyCore OS to get a tor browser running because there is no "armhf" binary available. I would like to use TinyCore instead of TailsOS because I assume the latter would use more ressources of my Pi4.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.