4

I have created a new user account as I dont want to use the default Pi account.

Now under my new user account, the WiFi dongle isnt detected (in wpa_gui program the Adapter and Network dropdown lists are blank). There is a message shown:

could not get status from wpa_supplicant

However under the default Pi account it is detected and WiFi works. What could be the problem?

  • Sounds like a permissions issue. Could you run groups USERNAME and post the output? – RPiAwesomeness Jan 27 '14 at 15:33
  • The output is user : user (where user is my username) – synthesis Jan 27 '14 at 15:48
  • That would be probably your issue. Your user doesn't have permissions to access network stuff. Lemme finish answering another question and get back to you. – RPiAwesomeness Jan 27 '14 at 15:54
  • 1
    Run sudo usermod -a -G netdev USER and reboot and then try out the WiFi. – RPiAwesomeness Jan 27 '14 at 16:43
  • Glad to help! I'll post that as answer so it can be marked. We're trying to get the site Q:A ratio and % answered up, so if you ask a question, don't forget to, if one solves your issue, mark it as answer! – RPiAwesomeness Jan 27 '14 at 21:43
6

The issue was solved in the comments, the OP's account didn't have the group permissions required for the networking.

He ran sudo usermod -a -G netdev USER and then rebooted and the issue was solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.