1

I am fairly new to this Raspberry community and I would like to set up mine Raspberry as pocket audio streamer / light computer. I have installed Raspbian where I want to run AirPlay (shairport-sync) audio only for now. But I am not able to get output through 3.5mm jack, just HDMI works.

I have tried to change setting via raspi-config and desktop UI settings. I have tried Volumio, where 3.5mm worked just fine, so no hardware "damage".

Any idea how I can get that work? :(

2
  • Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking.
    – Community Bot
    Oct 8, 2021 at 21:08
  • if running desktop change default audio device. which desktop ui did you try?
    – Abel
    Oct 9, 2021 at 20:52

2 Answers 2

0

The pimoroni airdac script will work, select 0 when it asks you what output

    curl -sS get.pimoroni.com/airdac | bash

or if you already have airplay installed you may only need to edit your config.txt file

    sudo nano /boot/config.txt 

and uncomment these if they are commented out

    # Enable audio (loads snd_bcm2835)
    dtparam=audio=on
0

That is interesting, I’m trying to do the exact opposite on my raspberry pi3b and I’m getting output only through the 3.5 mm jack, can please tell me all the steps you followed in order to get the hdmi port working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.