1

I bought the new HD RPi camera and want to connect it to my RPi 3. I checked on the Rpi website that raspistill is being replaced by libcamera, so I updated the OS to the most recent build (Bullseye) and installed libcamera-apps via apt-get.

pi@raspberrypi:~ $ neofetch --off
pi@raspberrypi
--------------
OS: Debian GNU/Linux 11 (bullseye) aarch64
Host: Raspberry Pi 3 Model B Rev 1.2
Kernel: 5.10.63-v8+
Uptime: 1 min
Packages: 1397 (dpkg)
Shell: bash 5.1.4
Resolution: 1920x1080
WM: Weston WM
Theme: Adwaita [GTK3]
Icons: Adwaita [GTK3]
Terminal: /dev/pts/0
CPU: BCM2835 (4) @ 1.200GHz
Memory: 259MiB / 909MiB

When I run the libcamera-hello I get:

pi@raspberrypi:~ $ libcamera-hello
[0:01:57.570234297] [1429]  INFO Camera camera_manager.cpp:294 libcamera v0.0.0
ERROR: *** no cameras available ***

The official website mentioned that:

When running a Raspberry Pi OS based on Bullseye or later, the 5 basic libcamera-apps are already installed. In this case, official Raspberry Pi cameras will also be detected and enabled automatically.

I would appreciate any suggestions!

4
  • 1
    "I would appreciate any suggestions!" 1. Don't EVER use rpi-update. 2. If you want to test pre-release OS check the limitations - specifically camera doesn't work.
    – Milliways
    Oct 12 '21 at 6:12
  • Do you know where I could get a working Bullseye image that has libcamera preinstalled?
    – Dawid
    Oct 12 '21 at 15:49
  • You will have to wait until it is released. Libcamera is in Buster.
    – Milliways
    Oct 12 '21 at 21:36
  • I have the same issue on buster with the official high quality camera and libcamera. I can only live preview with qv4l2
    – sleort
    Oct 15 '21 at 15:08
0

I had a similar issue with my pi3, and the cameraV2. I finally solved it. Here is one hint from the documentation:

Pi 3 and older devices may not by default be using the correct display driver. Refer to the /boot/config.txt file and ensure that either dtoverlay=vc4-fkms-v3d or dtoverlay=vc4-kms-v3d is currently active. Please reboot if you needed to change this.

What it doesn't say is to ensure the "dtoverlay" statement is in the [all] section, not the [pi4] section. Since you have a pi3, I think this might apply to you too. I did not have to upgrade beyond buster.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.