0

My Raspberry Pi 4 was originally loaded with Ubuntu 21.04, but after yesterday's release of 21.10, I upgraded using the do-release-upgrade command.

Among the other upgraded packages, there was a new Linux kernel: prior to the upgrade, the kernel version was 5.11.0-1019-raspi, while a new version 5.13.0-1008-raspi was installed in the course of the upgrade.

After the requested reboot at the end of the upgrade process, I found out that kernel version 5.11.0-1019-raspi was still in use. I have attempted to reinstall modules such as linux-image-5.13.0-1008-raspi, linux-image-raspi linux-modules-5.13.0-1008-raspi and linux-raspi, as well as removing the old kernel version. I have confirmed that /boot/vmlinuz and /boot/firmware/vmlinuz point to the same file, and it is the one for version 5.13.0-1008-raspi. Furthermore, after removing the old version, even vmlinuz.old points to the new version, so I have no idea where the system is fetching the old version from. Note that there have been quite a few reboots in the process, even a physical one by removing the power cable.

Regardless of everything done above, the system still boots to 5.11.0-1019-raspi. I suspect there's a missing installation step that updates some kind of onboard memory on the Raspberry Pi.

Note that, ever since installing Ubuntu 21.04 in this board a few months ago, I've seen apt upgrade install new kernel versions -- I am made aware of this due to the need to recompile a custom kernel module. Thus, the upgrade has worked automatically in the past. I'm not sure why it's not working this time.

My question is: what do I need to do make the Raspberry Pi boot the new version of the kernel?

EDIT: adding the information requested in the comments:

$ mount | grep boot
/dev/mmcblk0p1 on /boot/firmware type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
$ ls -R /boot
/boot:
System.map-5.11.0-1019-raspi  config-5.11.0-1019-raspi  config.txt  dtb-5.13.0-1008-raspi  firmware  initrd.img                    initrd.img.old  vmlinuz-5.13.0-1008-raspi
System.map-5.13.0-1008-raspi  config-5.13.0-1008-raspi  dtb         dtbs                   grub      initrd.img-5.13.0-1008-raspi  vmlinuz         vmlinuz.old

/boot/dtbs:
5.11.0-1007-raspi  5.11.0-1019-raspi  5.13.0-1008-raspi

/boot/dtbs/5.11.0-1007-raspi:
bcm2711-rpi-4-b.dtb.bak

/boot/dtbs/5.11.0-1019-raspi:
bcm2711-rpi-4-b.dtb.bak

/boot/dtbs/5.13.0-1008-raspi:
bcm2711-rpi-4-b.dtb  bcm2711-rpi-4-b.dtb.bak

/boot/firmware:
README                        bcm2710-rpi-cm3.dtb      bcm2711-rpi-cm4.dtb.bak       bcm2837-rpi-cm3-io3.dtb      config.txt        fixup4db.dat      fixup_db.dat.bak  start.elf         start4db.elf.bak  start_x.elf          uboot_rpi_arm64.bin.bak
bcm2710-rpi-2-b.dtb           bcm2710-rpi-cm3.dtb.bak  bcm2837-rpi-3-a-plus.dtb      bcm2837-rpi-cm3-io3.dtb.bak  fixup.dat         fixup4db.dat.bak  fixup_x.dat       start.elf.bak     start4x.elf       start_x.elf.bak      vmlinuz
bcm2710-rpi-2-b.dtb.bak       bcm2711-rpi-4-b.dtb      bcm2837-rpi-3-a-plus.dtb.bak  boot.scr                     fixup.dat.bak     fixup4x.dat       fixup_x.dat.bak   start4.elf        start4x.elf.bak   uboot_rpi_3.bin      vmlinuz.bak
bcm2710-rpi-3-b-plus.dtb      bcm2711-rpi-4-b.dtb.bak  bcm2837-rpi-3-b-plus.dtb      boot.scr.bak                 fixup4.dat        fixup4x.dat.bak   initrd.img        start4.elf.bak    start_cd.elf      uboot_rpi_3.bin.bak
bcm2710-rpi-3-b-plus.dtb.bak  bcm2711-rpi-400.dtb      bcm2837-rpi-3-b-plus.dtb.bak  bootcode.bin                 fixup4.dat.bak    fixup_cd.dat      initrd.img.bak    start4cd.elf      start_cd.elf.bak  uboot_rpi_4.bin
bcm2710-rpi-3-b.dtb           bcm2711-rpi-400.dtb.bak  bcm2837-rpi-3-b.dtb           bootcode.bin.bak             fixup4cd.dat      fixup_cd.dat.bak  overlay_map.dtb   start4cd.elf.bak  start_db.elf      uboot_rpi_4.bin.bak
bcm2710-rpi-3-b.dtb.bak       bcm2711-rpi-cm4.dtb      bcm2837-rpi-3-b.dtb.bak       cmdline.txt                  fixup4cd.dat.bak  fixup_db.dat      overlays          start4db.elf      start_db.elf.bak  uboot_rpi_arm64.bin
4
  • 1
    I suggest you ask Ubuntu.
    – joan
    Oct 15, 2021 at 14:30
  • Cross-posted to Ask Ubuntu.
    – swineone
    Oct 15, 2021 at 17:14
  • AFAIK Ubuntu do-release-upgrade never worked on the Pi. This tries to upgrade EFI. You needed a different (kluge) to upgrade kernel.
    – Milliways
    Oct 15, 2021 at 22:02
  • NOTE Raspberry Pi OS has its own kluge to update files on VFAT partition (which involves copying to ext partition).
    – Milliways
    Oct 15, 2021 at 22:04

1 Answer 1

0

This command fixed it:

sudo flash-kernel 5.13.0-1008-raspi

I'm pretty sure I saw the same output in the course of my attempts described in the question, but anyway, it's fixed now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.