I want to connect my PI to the internet using my old Wireless Dongle Netgear WG111.

According to this blog post I did the following:

  1. Edit the file: /etc/wpa_supplicant/wpa_supplicant.conf and append the following:

  2. Make sure the interface is listed using the command lsusb which did output the adapter:

    Bus 001 Device 004: ID 0846:4240 NetGear, Inc. WG111(v1) rev 2 54 Mbps Wireless [Intersil ISL3887]
  3. Start the interface by using the command sudo ifup wlan0. But this resulted in the following erros:

    wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
    run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
    Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
    wpa_supplicant: /sbin/wpa_cli daemon failed to start
    run-parts: /etc/network/if-up.d/wpasupplicant exited with return code 1
  4. When I now run this command again it tells me ifup: interface wlan0 already configured but if I run ifconfig the interface is not there.

I don't see what I've done wrong so suggestions and advice are very welcome.


Here are the contents of the related files.

cat /etc/network/interfaces

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp


ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

  • Please post the content of /etc/network/interfaces and /etc/wpa_supplicant/wpa_supplicant.conf.
    – M Noit
    Commented Jan 28, 2014 at 13:47
  • @MNoit I did update my post with the contents. Thanks for pointing this out.
    – Besi
    Commented Jan 28, 2014 at 14:23

3 Answers 3


Fortunately, you have posted the output of lsusb with the Vendor ID.

This particular release of the old Netgear WG111 seems to need the p54usb driver. If

modprobe p54usb

gives nothing, please have a look at Linux Wireless for further information and the firmware.

Whether it is really worth the effort is of course up to you.


As your dongle is old, it may not work with raspberry pi. My old dongle doesn't. You could buy a wipi, a dongle made for raspberry pi, or you could connect via your computer. Instructions for connection via computer at: http://pihw.wordpress.com/guides/direct-network-connection/.


I encountered the same wpa_supplicant errors, except using an EDUP (realtek) wifi adapter.

Bus 001 Device 002: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter

For me the errors were most likely caused by an rpi-update that was interrupted and failed before finishing, which meant that after rebooting the 8192cu kernel module was not loaded.

I fixed it by copying the modules under the old kernel folder /lib/modules/3.xx.yy/kernel/drivers/net/wireless to the new (eg. from 3.12.18 to 3.12.20), then running depmod -a, and finally rebooting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.