1

I'm having torrent issues, and they're not caused by the torrent itself, since the same torrent from my pc downlads 5x faster than in the Pi.

My setup:

  • Raspberry Pi 4B with 8GB RAM.
  • MicroSD 128GB (boot)
  • External USB Nvme M2 128GB disk. (/)
  • External USB mechanical 2TB disk (NTFS in /media/ntfs)
  • OS Raspbian GNU/Linux 10 (buster)
  • Kernel Linux 5.10.63-v7l+ armv7l
  • 1gbps simmetric fiber connection to internet

Tried with 3 different torrent clients: Deluge, Transmission and qBitTorrent

Speedtest on my pc gives 927mbit download, 917mbit upload, 2ms ping approx.

Speedtest in the PI gives 760mbit download, 804mbit upload, same ping.

I try to download an official ubuntu .iso torrent to be sure it's an official one, with enough peers.

In the PC, using qBitTorrent after some seconds initializing, it ramps easily to 30MB/s (megabytes). In the raspberry, no matter which client I use.. won't go further than 6/7 MB/s (megabytes)

Is there anything I should change in my config to speed up torrent downloads from the PI?

Here's my transmission config :

{
    "alt-speed-down": 50,
    "alt-speed-enabled": false,
    "alt-speed-time-begin": 540,
    "alt-speed-time-day": 127,
    "alt-speed-time-enabled": false,
    "alt-speed-time-end": 1020,
    "alt-speed-up": 50,
    "bind-address-ipv4": "0.0.0.0",
    "bind-address-ipv6": "::",
    "blocklist-enabled": false,
    "blocklist-url": "http://www.example.com/blocklist",
    "cache-size-mb": 4,
    "dht-enabled": true,
    "download-dir": "/media/nvme/download",
    "download-limit": 100,
    "download-limit-enabled": 0,
    "download-queue-enabled": true,
    "download-queue-size": 5,
    "encryption": 1,
    "idle-seeding-limit": 30,
    "idle-seeding-limit-enabled": false,
    "incomplete-dir": "/media/nvme/download",
    "incomplete-dir-enabled": false,
    "lpd-enabled": false,
    "max-peers-global": 200,
    "message-level": 1,
    "peer-congestion-algorithm": "",
    "peer-id-ttl-hours": 6,
    "peer-limit-global": 200,
    "peer-limit-per-torrent": 50,
    "peer-port": 51413,
    "peer-port-random-high": 65535,
    "peer-port-random-low": 49152,
    "peer-port-random-on-start": false,
    "peer-socket-tos": "default",
    "pex-enabled": true,
    "port-forwarding-enabled": false,
    "preallocation": 1,
    "prefetch-enabled": true,
    "queue-stalled-enabled": true,
    "queue-stalled-minutes": 30,
    "ratio-limit": 2,
    "ratio-limit-enabled": false,
    "rename-partial-files": true,
    "rpc-authentication-required": true,
    "rpc-bind-address": "0.0.0.0",
    "rpc-enabled": true,
    "rpc-host-whitelist": "",
    "rpc-host-whitelist-enabled": true,
    "rpc-password": "##secret##",
    "rpc-port": 9091,
    "rpc-url": "/transmission/",
    "rpc-username": "##secret##",
    "rpc-whitelist": "192.168.*.*",
    "rpc-whitelist-enabled": true,
    "scrape-paused-torrents-enabled": true,
    "script-torrent-done-enabled": false,
    "script-torrent-done-filename": "",   "seed-queue-enabled": false,
    "seed-queue-size": 10,
    "speed-limit-down": 100,
    "speed-limit-down-enabled": false,
    "speed-limit-up": 100,
    "speed-limit-up-enabled": false,
    "start-added-torrents": true,
    "trash-original-torrent-files": false,
    "umask": 18,
    "upload-limit": 100,
    "upload-limit-enabled": 0,
    "upload-slots-per-torrent": 14,
    "utp-enabled": true
}
5
  • 1
    Why are you using a 128GB SD card for boot? Sounds like you're wasting a perfectly good card, 100-200 MB would be plenty for a boot partition. If your SSD is /, then what is /media/nvme? Also, are you using the same transmission config file on the PC and the Pi? And you forgot to mention how the PC and the Pi are connected to your network, the Pi has no fiber optics connectors so you're most likely using Ethernet or WiFi. Oct 20, 2021 at 6:58
  • 1
    I bought the microsd first thinking about having everything there... but then when I already had it, I thought it would be better to have a nvme hd... so yes, it's a waste of space but it is what it is... Oct 21, 2021 at 10:11
  • The /media/nvme folder is the nvme mounted unit... Oct 21, 2021 at 10:11
  • I'm not using transmission in the pc... but I tried with transmission, deluge and qbittorrent in my pi with the same horrible results... anyway, I found a solution and now it's dowloading faster... I had port forwarding off in the transmission config... Oct 21, 2021 at 10:12
  • It doesn't matter if it's transmission, deluge or qbittorrent: using the same configuration on a Pi and the PC would have revealed the problem. Anyway, you found it already. Oct 21, 2021 at 10:40

1 Answer 1

1

Note that it's better to configure port forwarding in your router, rather than allowing a torrent client to do so. If any computer in your local network gets infected, the malware will be able to open ports just like your torrent client did, and host a phishing site or an illegal drugs/guns/porn shop on your machine.

Opening a port in the router config will make only a single port available, and only for the Pi, making it much harder for malware to exploit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.