1

Thanks, I upgraded and it works now.

1
3

The "short answer" - which often resolves the issue - is to use apt instead of apt-get. If you're interested in further details, please see this answer, and/or this answer.

FWIW, the same situation occurred during the RPi OS upgrade to buster in 2019. Here's another solution that was discovered then that retains use of apt-get - it may still be useful for this upgrade to bullseye.

Not the answer you're looking for? Browse other questions tagged or ask your own question.