0

I have a Pi Zero w.

it has been set up with a standard rasbpian imager and OS and latest files off the OEM website.

the boot drive also has an ssh file and a wpa_supplicant.conf file with necessary network credentials.

The first time I tried to ping it from my windows 8.1 PC, it returned that "ping request could not find host raspberrypi.local. please check the name and try again".

when I tried it again on another Windows 10 PC on the same network it went through flawlessly and I went on to run it through a standard config and set up a static IP address after which Pi-Hole was successfully set up and deployed.

I still face the issue of being unable to ping it from my windows 8.1 PC.

I have also downloaded the appropriate ssh files and added the directory to the path environment variable.

I've tried a lot of forums and am running out of options.

3
  • 1
    Try to access it using the IP address.
    – rtaft
    Nov 1, 2021 at 17:04
  • 1
    This question does not appear to be specific to the Raspberry Pi. As you've phrased the question, it seems clear the issue is not with the RPi, but rather your Windows machine. If you've got evidence to the contrary, please edit your question to add it. Otherwise, your question may be closed as "off topic".
    – Seamus
    Nov 1, 2021 at 18:08
  • Windows 8 doesn't have mDNS support!
    – MatsK
    Nov 2, 2021 at 14:36

1 Answer 1

1

Your question is almost certainly off-topic, but here's something that may explain the difference in outcomes between your Win 10 & Win 8 PCs:

Briefly, it's called "Zero Configuration Networking". I say it may explain the difference because I know very little about Windows, so this is more speculation, rather than an answer based on direct knowledge.

That said, I recall hearing/reading that Windows did not support "Zero Configuration Networking" out-of-the-box - it required the addition of some software (Apple's Bonjour maybe?). Perhaps it's the case that your older Win 8 doesn't support ZCN, but the newer Win 10 does? Try an Internet search to get further details.

I also suspect that @rtaft's comment/suggestion may resolve your issue - but perhaps at the expense of creating another issue! What am I talking about? We get a lot of questions here from people who attempt to set up a fixed IP address, but bungle it because they fail to read the documentation (man dhcpcd and man dhcpcd-conf). Please don't make that mistake; there's very seldom a sound reason for setting up a fixed IP, but if you do it, please read the docs & do it correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.