0

I just recently got my raspberry pi. I'm running NOOBS on a 16GB SD card. I've been running xbmc from the terminal, I ssh in from my laptop, run XBMC which is displayed on my TV.

I set up my library on a usb hard drive, and added the library to XBMC. I watched a couple of films, no problem, everything works fine. Once the app is running I'm controlling it with the android XBMC controller.

After the second film, I was playing around with the display settings, as the menus were getting very slightly clipped. Everything was fine. I tried to download a new skin, it appeared to be working, but when it had finished there was nothing new in the available skins. I tried playing another movie, but the application froze as I was navigating the menu. I left it for a couple of minutes but it never came back to life, so I killed the process and attempted to restart it, then I get the error:

ERROR: Unable to create application. Exiting

I've uninstalled the app and reinstalled using both:

sudo apt-get remove xbmc

and

sudo apt-get purge xbmc

But it doesn't make any difference, the error persists.

Can anyone help?

-1

I had the same problem after I upgraded my Raspberry Pi to the last version with rpi-update.

I fixed it by deleting the contents of the XBMC temp user directory with:

$ rm -r ~/.xbmc/temp/*

EDIT:

If that didn't solve the problem, try to deleting the file ~/.xbmc/userdata/guisettings.xml, but be CAREFUL. You will lose your XBMC configuration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.