I am attempting to install blender on essentially a new Raspberry Pi 4. After running both apt-get update and apt-get upgrade, I get the following error message when running apt-get install blender:

Err:1 http://raspbian.raspberrypi.org/raspbian buster/main armhf mariadb-common all 1:10.3.23-0+deb10u1
  404  Not Found [IP: 2a00:1098:0:80:1000:75:0:3 80]
Err:2 http://raspbian.raspberrypi.org/raspbian buster/main armhf libmariadb3 armhf 1:10.3.23-0+deb10u1
  404  Not Found [IP: 2a00:1098:0:80:1000:75:0:3 80]
Err:3 http://raspbian.raspberrypi.org/raspbian buster/main armhf libxerces-c3.2 armhf 3.2.2+debian-1+b1
  404  Not Found [IP: 2a00:1098:0:80:1000:75:0:3 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbian/pool/main/m/mariadb-10.3/mariadb-common_10.3.23-0+deb10u1_all.deb  404  Not Found [IP: 2a00:1098:0:80:1000:75:0:3 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbian/pool/main/m/mariadb-10.3/libmariadb3_10.3.23-0+deb10u1_armhf.deb  404  Not Found [IP: 2a00:1098:0:80:1000:75:0:3 80]
E: Failed to fetch http://raspbian.raspberrypi.org/raspbian/pool/main/x/xerces-c/libxerces-c3.2_3.2.2+debian-1+b1_armhf.deb  404  Not Found [IP: 2a00:1098:0:80:1000:75:0:3 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Running apt-get update --fix-missing followed by the same install blender command produces the same result.

My only clue as to what was wrong was the following message I get when doing apt-get update:

E: Repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' changed its 'Suite' value from 'stable' to 'oldstable'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.

I researched this error and found that this was due to a compatibility issue related to a recent debian release (bullseye) that has not yet fully made it to the pi. I ran the update script found on this post:


and retried the install of blender. The install of blender was successful, but upon launching it, it says that it requires opengl 3.3 which is beyond the capacity of the pi. Blender.org says that blender version 2.79 should not require such a recent version of opengl, but when I do:

apt-get install blender=2.79.b+dfsg0-7 -V

then I get the same error as when previously installing blender.

What do I do? I am the faculty advisor of a high school computer club using these things!


1 Answer 1


Forget apt-get and use apt.

You should then be prompted to accept.

apt-get is the command-line tool for handling packages, and may be considered the user's "back-end" to other tools using the APT library.

apt provides a high-level commandline interface for the package management system. It is intended as an end user interface and enables some options better suited for interactive usage by default compared to more specialized APT tools like apt-get(8) and apt-cache(8).

If you have run RonR's script you should restore from your backup (or do a fresh install).
This is intended for advanced users to perform testing.

Wait for the official release of Raspberry Pi OS Bullseye (which will require a fresh install).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.